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1
Installing the Operating System

Depending on the model, Microsoft Windows 2000 Professional or Windows XP Professional is 
preinstalled on the workstation and will be configured automatically the first time the 
workstation is turned on. 

Ä
CAUTION: Do not add optional hardware devices to your workstation until the operating system is 
successfully installed. Doing so may cause errors and may prevent the operating system from installing 
properly.

Ä
CAUTION: Once the automatic installation has begun, DO NOT TURN OFF THE WORKSTATION 
UNTIL THE PROCESS IS COMPLETE. Turning off the workstation during the installation process might 
damage the software that runs the workstation.

The first time the workstation is turned on, the operating system is automatically installed. This 
takes approximately 10 minutes, depending on the system hardware configuration. At the 
beginning of the installation process, you may be prompted to select the appropriate language for 
the operating system. Read and follow the instructions that appear on the screen to complete the 
installation. During this process, do not turn off your workstation unless you are directed to do 
so.

1.1 Installing or Upgrading Device Drivers 
To install hardware devices such as a printer, a display adapter, or network adapter after the 
operating system installation is completed, the operating system needs access to the appropriate 
software drivers for the devices.

The I386 directory and its subdirectories provide the HP- or Compaq-specific integration of the 
operating system for the workstation model and include device drivers supported by Windows 
2000.

When prompted for the I386 directory on the operating system CD, replace the path specification 
with C:\I386 or use the browse button of the dialog box to browse the system for the I386 folder. 

1.2 Creating an Emergency Repair Diskette 

1.2.1 Windows 2000
1. Click Start > Programs > Accessories > System Tools > Backup.

2. Select the menu option Tools, then select Create an Emergency Disk.

3. Follow the instructions that appear on the screen.
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1.3 Using the Emergency Repair Diskette

1.3.1 Windows 2000
1. Insert the diskette into the diskette drive and restart the workstation (on some models you 

may boot to the Windows 2000 CD).

2. Press Enter to start the repair process, then choose to repair the system.

3. Select the Emergency Repair Process. 

4. Follow the instructions that appear on the screen.

1.4 Converting to NTFS

1.4.1 Windows 2000 
To convert an existing partition from a FAT 32 partition to an NTFS partition, double-click the 
NTFS Convert icon on the desktop. Carefully read and follow the directions that appear on the 
screen.

1.4.2 Windows XP Professional
The Windows XP Professional operating systems handle only NTFS-formatted drives. When 
installed, XP will, if necessary, automatically convert a FAT32 drive to NTFS. 

1.5 HP Software
The Microsoft Windows 2000 Professional or Windows XP Professional operating system is 
preinstalled on the workstation and will be configured automatically the first time the 
workstation is turned on. The following HP software will also be installed at that time on selected 
models: 

■ Computer Setup Utilities and diagnostic features

■ HP Support Software including device drivers

■ Configuration Record

■ Online Safety & Comfort Guide

■ Enhanced HP Insight Personal Edition (Diagnostics for Windows)

■ DMI Support

■ Power Management with energy saver features

■ Security Management tools

■ Software Support Management tools
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Certain drivers and utilities are available only in selected languages. You can obtain the latest 
version of these files, in English and selected other languages, in one of three ways:

■ Support Software CD 

■ HP web site at www.hp.com

■ Restore Plus! CD, supplied with many models

✎ Additional HP software may be required in certain situations. 
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2
Computer Setup Utilities and Diagnostic 

Features

Computer Setup Utilities (F10) and diagnostic features provide information needed about the 
workstation when contacting Customer Support. These tools can also be used to:

■ Change factory default settings and to set or change the system configuration, which may be 
necessary when you add or remove hardware.

■ Determine if all of the devices installed on the workstation are recognized by the system and 
functioning properly.

■ Determine information about the operating environment of the workstation.

■ Solve system configuration errors detected but not automatically fixed during the Power-On 
Self-Test (POST).

■ Establish and manage passwords and other security features.

■ Establish and manage energy-saving timeouts.

✎ All features identified in this chapter may not be available on all HP products.

2.1 Power-On Self-Test (POST)
POST is a series of diagnostic tests that runs automatically when the system is turned on. POST 
checks the following items to ensure that the workstation is functioning properly:

■ Keyboard

■ Memory modules

■ Diskette drives

■ All IDE mass storage devices 

■ Processors

■ Controllers

✎ If the Power-On Password is set, a key icon appears on the screen while POST is running. You 
will need to enter the password before continuing. Refer to Chapter 3, Section 3.1for information 
on setting, deleting, or bypassing the password.

If POST finds an error in the system, an audible and/or visual message occurs. For POST error 
messages and their solutions refer to Appendix C, “POST Error Messages.”
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2.2 Computer Setup Utilities
Use Computer Setup Utilities (F10) to: 

■ Modify or restore factory default settings.

■ Set the system date and time.

■ Set, view, change, or verify the system configuration including settings for processor, 
graphics, memory, audio, storage, communications, and input devices.

■ Modify the boot order of bootable devices such as hard drives, diskette drives, optical drives, 
or LS-120 drives.

■ Configure the boot priority of IDE (ATA) hard drive controllers.

■ Enable Quick Boot which is faster than Full Boot but does not run all of the diagnostic tests 
run during a Full Boot. You can set your system to:

❏ always Quick Boot (default);
❏ periodically Full Boot (from every 1 to 30 days); or
❏ always Full Boot.

■ Enable or disable Network Server Mode, which allows the workstation to boot the operating 
system when the power-on password is enabled with or without a keyboard or mouse 
attached. When attached to the system, the keyboard and mouse remain locked until the 
power-on password is entered.

■ Select POST Messages Enabled or Disabled to change the display status of Power-On 
Self-Test (POST) messages. POST Messages Disabled suppresses most POST messages, 
such as memory count, product name, and other non-error text messages. If a POST error 
occurs, the error is displayed regardless of the mode selected. To manually switch to POST 
Messages Enabled during POST, press any key (except F1 through F12).

■ Establish an Ownership Tag, the text of which is displayed each time the system is turned on 
or restarted.

■ Enter the Asset Tag or property identification number assigned by your company to this 
workstation.

■ Enable power-on password prompting during system restarts (warm boots) as well as during 
power-on.

■ Establish a setup password that controls access to Computer Setup (F10) Utility and the 
settings described in this section.

■ Secure the integrated I/O functionality, including the serial, USB, or parallel ports, audio, or 
embedded NIC, so that they cannot be used until they are unsecured.

■ Enable or disable Master Boot Record (MBR) Security.

■ Enable or disable removable media boot ability.

■ Enable or disable removable media write ability (when supported by hardware).

■ Solve system configuration errors detected but not automatically fixed during the Power-On 
Self-Test (POST).

■ Replicate your system setup by saving system configuration information on diskette and 
restoring it on one or more workstations.

■ Execute self-tests on a specified IDE (ATA) hard drive (when supported by the drive).
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2.2.1 Using Computer Setup (F10) Utilities 
Computer Setup can be accessed only by turning on the workstation or restarting the system. To 
access the Computer Setup Utilities menu, complete the following steps: 

1. Turn on or restart the workstation. If you are in Windows, click Start >Shut Down >Restart 
the Computer. 

2. Press the F10 key as soon as the monitor light turns green. 

✎ If you do not press the F10 key at the appropriate time, you must turn the workstation off, then 
on again, and press the F10 key again to access the utility.

3. Select your language from the list and press the Enter key.

4. A choice of four headings appears in the Computer Setup Utilities menu: File, Storage, 
Security, and Advanced. 

5. Use the arrow (left and right) keys to select the appropriate heading. Use the arrow (up and 
down) keys to select the option you want, then press Enter. To return to the Computer Setup 
Utilities menu, press Esc.

6. To apply and save changes, select File > Save Changes and Exit. 

❏ If you have made changes that you do not want applied, select Ignore Changes and 
Exit.

❏ To reset to factory settings, select Set Defaults and Exit. This option will restore the 
original factory system defaults.

Ä
CAUTION: Do NOT turn the workstation power OFF while the ROM is saving your F10 Computer Setup 
changes because the CMOS could become corrupted. It is safe to turn off all power to the workstation 
after you exit the F10 Setup screen. 
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2.2.2 Computer Setup Menu
.

Heading Option Description

File System Information Lists product name, processor type/speed/stepping, cache size 
(L1/L2), system ROM family and version, installed memory size, 
chassis serial number, integrated MAC for enabled or 
embedded NIC (if applicable), and asset tracking number.

About Displays copyright information.

Set Time and Date Allows you to set system time and date.

Save to Diskette Saves system configuration, including CMOS, to a formatted 
blank 1.44-MB diskette in file CPQsetup.txt. Save/Restore for 
DiskOnKey is supported.

Restore from 
Diskette

Restores system configuration from a diskette. Save/Restore for 
DiskOnKey is supported.

Set Defaults and 
Exit

Restores factory default settings which includes clearing any 
established passwords.

Ignore Changes 
and Exit

Exits Computer Setup without applying or saving any changes.

Save Changes and 
Exit

Saves changes to system configuration and exits Computer 
Setup.

Storage Device 
Configuration

Lists all installed non-SCSI storage devices. 
When a device is selected, detailed information and options 
are displayed. The following options may be presented:

Diskette Type (For legacy diskette drives only) 
Identifies the highest capacity media type accepted by the 
diskette drive. Options are 3.5" 1.44 MB and 5.25" 1.2 MB.

Drive Emulation (IDE devices only) 
Allows you to select a drive emulation type for a storage device. 
(For example, a Zip drive can be made bootable by selecting 
disk emulation.)

Drive Type Emulation Options

ATAPI Zip drive None (treated as Other).

Diskette (treated as diskette drive).

IDE Hard disk None (treated as Other) Disk (treated as 
hard drive).

Legacy diskette No emulation options available.

IDE CD-ROM No emulation options available.

Storage 
(continued)

Device 
Configuration 
(continued)

Drive Type 
(continued)

Emulation Options 
(continued)

ATAPI LS-120 None (treated as Other).
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Diskette (treated as diskette drive).

Transfer Mode (IDE devices only) 
Specifies the active data transfer mode. Options (subject to 
device capabilities) are PIO 0, Max PIO, Enhanced DMA, Ultra 
DMA 0, and Max UDMA.

Translation Mode (IDE disks only) 
Lets you select the translation mode to be used for the device. 
This enables the BIOS to access disks partitioned and formatted 
on other systems and may be necessary for users of older 
versions of Unix (e.g., SCO Unix version 3.2). Options are 
Bit-Shift, LBA Assisted, User, and None.

Ä Ordinarily, the translation mode selected automatically by the 
BIOS should not be changed. If the selected translation mode 
is not compatible with the translation mode that was active 
when the disk was partitioned and formatted, the data on the 
disk will be inaccessible.

Translation Parameters (IDE disks only) 
Allows you to specify the parameters (logical cylinders, heads, 
and sectors per track) used by the BIOS to translate disk I/O 
requests (from the operating system or an application) into terms 
the hard drive can accept. Logical cylinders may not exceed 
1024. The number of heads may not exceed 256. The number 
of sectors per track may not exceed 63. These fields are only 
visible and changeable when the drive translation mode is set 
to User.

Multisector Transfers (IDE disks only) 
Specifies how many sectors are transferred per multi-sector PIO 
operation. Options (subject to device capabilities) are Disabled, 
8, and 16. 

Options Removable Media Boot 
Enables/disables ability to boot the system from removable 
media.
Removable Media Write
Enables/disables ability to write data to removable media.

✎ This feature applies only to legacy diskette, (IDE/ATA) 
LS-120 Superdisk, (IDE/ATA) LS-240 Superdisk, and 
(IDE/ATA) PD-optical drives.

✎ After saving changes to Removable Media Boot, the 
workstation will restart. Manually, turn the workstation off, 
then on. 

Primary IDE Controller * 
Allows you to enable or disable the primary IDE/ATA controller.

*Option supported on select models.

Storage 
(continued)

Options 
(continued)

Secondary IDE Controller *
Allows you to enable or disable the secondary IDE/ATA 
controller.

Heading Option Description
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Diskette MBR Validation * 
Allows you to enable or disable strict validation of the diskette 
Master Boot Record (MBR). 

✎ If you use a bootable diskette image that you know to be 
valid, and it does not boot with Diskette MBR Validation 
enabled, you may need to disable this option in order to use 
the diskette.

BIOS IDE DMA Transfers
Allows you to control how BIOS disk I/O requests are serviced. 
When “Enable” is selected, the BIOS will service all disk I/O 
requests with DMA data transfers. When “Disable” is selected, 
the BIOS will service all disk I/O requests with PIO data 
transfers.

SATA Configuration *
Allows you to choose how the SATA controller and devices are 
accessed by the operating system. 
“Add as a Separate Controller” is the default option. Up to 4 
PATA and 2 SATA devices may be accessed in this mode. The 
SATA and PATA controllers appear as two separate IDE 
controllers. Use this option with Win 2K and Win XP.

• SATA 0 is seen as SATA Primary Device 0
• SATA 1 (if present) is seen as SATA Secondary Device 0

“Replace Primary IDE Controller” is the other option. Up to 2 
PATA and 2 SATA devices may be accessed in this mode. The 
SATA and PATA controllers appear as one combined IDE 
controller. Use this option with Win 98 and earlier operating 
systems.

• SATA 0 replaces PATA Primary Device 0
• SATA 1 replaces PATA Primary Device 1

IDE DPS Self-Test Allows you to execute self-tests on IDE hard drives capable of 
performing the Drive Protection System (DPS) self-tests.

✎ This selection will only appear when at least one drive 
capable of performing the IDE DPS self-tests is attached to the 
system.

Controller Order  Allows you to specify the order of the attached hard drive 
controllers. The first hard drive controller in the order will have 
priority in the boot sequence and will be recognized as drive C 
(if any devices are attached).

Heading Option Description
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Storage 
(continued)

Boot Order Allows you to specify the order in which attached peripheral 
devices (such as a diskette drive, hard drive, optical drive, or 
network interface card) are checked for bootable operating 
system image. Each device on the list may be individually 
excluded from or included for consideration as a bootable 
operating system source.

✎ MS-DOS drive lettering assignments may not apply after a 
non-MS-DOS operating system has started.

Shortcut to Temporarily Override Boot Order
To boot one time from a device other than the default device 
specified in Boot Order, restart the workstation and press F9 
when the F10=Setup message appears on the screen. After 
POST is completed, a list of bootable devices is displayed. Use 
the arrow keys to select the preferred bootable device and press 
Enter. The workstation then boots from the selected non-default 
device for this one time.

Security Setup Password Allows you to set and enables setup (administrator) password. 

✎ If the setup password is set, it is required to change 
Computer Setup options, flash the ROM, and make changes 
to certain plug and play settings under Windows.

See the Troubleshooting Guide for more information.

Power-On 
Password

Allows you to set and enable power-on password.

Password Options 
(This selection will 
appear only if a 
power-on 
password is set.)

Allows you to specify whether the password is required for 
warm boot (CTRL+ALT+DEL). 

Smart Cover Allows you to enable/disable Smart Cover Lock. 

✎ Notify User alerts the user that the sensor has detected that 
the cover has been removed. Setup Password requires that 
the setup password be entered to boot the workstation if the 
sensor detects that the cover has been removed. 

This feature is supported on select models only. 

Smart Sensor Allows you to:
Enable/disable the Smart Sensor.

✎ Notify User alerts the user that the sensor has detected that 
the cover has been removed. Setup Password requires that 
the setup password be entered to boot the workstation if the 
sensor detects that the cover has been removed.

This feature is supported on select models only. 

*Option supported on select models.

Heading Option Description
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Security 
(continued)

DriveLock* Allows you to assign or modify a master or user password for 
select IDE hard drives. When this feature is enabled, the user is 
prompted to provide one of the DriveLock passwords during 
POST. If neither is successfully entered, the hard drive will 
remain inaccessible until one of the passwords is successfully 
provided during a subsequent cold-boot sequence.

✎ This selection will only appear when at least one drive that 
supports the DriveLock feature is attached to the system.

This feature is supported on select models only.

Master Boot 
Record Security*

Allows you to enable or disable Master Boot Record (MBR) 
Security. 
When enabled, the BIOS rejects all requests to write to the MBR 
on the current bootable disk. Each time the workstation is 
powered on or rebooted, the BIOS compares the MBR of the 
bootable disk to the previously saved MBR. If changes are 
detected, you are given the option of saving the MBR on the 
current bootable disk, restoring the previously-saved MBR, or 
disabling MBR security. You must know the setup password if 
one is set.

✎ Disable MBR Security before intentionally changing the 
formatting or partitioning of the current bootable disk. 
Several disk utilities (such as FDISK and FORMAT) attempt to 
update the MBR.  
If MBR Security is enabled and disk accesses are being 
serviced by the BIOS, write requests to the MBR are rejected, 
causing the utilities to report errors.  
If MBR Security is enabled and disk accesses are being 
serviced by the operating system, any MBR change will be 
detected by the BIOS during the next reboot, and an MBR 
Security warning message will be displayed.

Save Master Boot 
Record*

Saves a backup copy of the Master Boot Record of the current 
bootable disk.

✎ Only appears if MBR Security is enabled.

Restore Master 
Boot Record*

Restores the backup Master Boot Record to the current bootable 
disk.

✎ Only appears if all of the following conditions are true: 
 
MBR Security is enabled. 
 
A backup copy of the MBR has been previously saved. 
 
The current bootable disk is the same disk from which the         
backup copy of the MBR was saved.

Ä Restoring a previously saved MBR after a disk utility or 
operating system has modified the MBR may cause the data 
on the disk to become inaccessible. Only restore a previously 
saved MBR ifyou are confident that the current bootable 
disk’s MBR has been corrupted or infected with a virus.

*Option supported on select models.

Heading Option Description
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Security 
(continued)

Device Security* Enables/disables serial ports A and B, parallel port, front USB 
ports, all USB ports, system audio, and network controllers 
(some models).

Network Service 
Boot

Enables/disables the workstation’s ability to boot from an 
operating system installed on a network server. (Feature 
available on NIC models only; the network controller must 
reside on the PCI bus or be embedded on the system board.)

System IDs Allows you to set:
• Asset tag (18-byte identifier) and ownership Tag (80-byte 

identifier displayed during POST). 
 
See Chapter 3, Desktop Management, in this Guide.

• Chassis serial number or Universal Unique Identifier (UUID) 
number. The UUID can only be updated if the current 
chassis serial number is invalid. (These ID numbers are 
normally set in the factory and are used to uniquely identify 
the system.)

Keyboard locale setting (for example, English or German) for 
System ID entry.

*Option supported on select models.

Heading Option Description
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Advanced** Power-On Options Allows you to set:
POST mode (QuickBoot, FullBoot, or FullBoot every 1-30 days).
POST messages (enable/disable).
Safe POST* (enable/disable). Enabling this feature allows the 
ROM to monitor add-in cards during boot. If an add-in card 
does not work or initialize correctly, then on the next boot all 
cards will be skipped during POST.
F9 prompt (enable/disable). Enabling this feature will display 
the text F9=Boot Menu during POST. Disabling this feature 
prevents the text from being displayed but pressing F9 will still 
access the Shortcut Boot (Order) Menu screen. See Storage > 
Boot Order for more information. 
F10 prompt (enable/disable). Enabling this feature will display 
the text F10=Setup during POST. Disabling this feature 
prevents the text from being displayed but pressing F10 will still 
access the Setup screen.
F12 prompt (enable/disable). Enabling this feature will display 
the text F12=Network Service Boot during POST. 
Disabling this feature prevents the text from being displayed but 
pressing F12 will still force the system to attempt booting from 
the network.
Option ROM* prompt (enable/disable). Enabling this feature 
will cause the system to display a message before loading 
options ROMs. 
Remote wakeup boot source (remote server/local hard drive).
After Power Loss (off/on): After power loss, if you connect your 
workstation to an electric power strip and would like to turn on 
power to the workstation using the switch on the power strip, set 
this option to ON.

✎ If you turn off power to your workstation using the switch on 
a power strip, you will not be able to use the suspend/sleep 
feature or the Remote Management features.

* Available on select models. 
**These options should be used by advanced users only.

Heading Option Description
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Advanced** 
(continued)

Power-On Options 
(continued)

Allows you to set: (continued)
POST Delay (in seconds) (enable/disable). Enabling this feature 
will add a user-specified delay to the POST process. This delay 
is sometimes needed for hard disks on some PCI cards that spin 
up very slowly; so slowly that they are not ready to boot by the 
time POST is finished. The POST delay also gives you more time 
to select F10 to enter Computer (F10) Setup.
I/O APIC Mode (enable/disable). Enabling this feature will 
allow Microsoft Windows Operating system to run optimally. 
This feature must be disabled for certain non-Microsoft 
Operating Systems to work properly.
ACPI/USB Buffers @ Top of Memory (enable/disable). 
Enabling this feature places USB memory buffers at the top of 
memory. The advantage of remapping is that it allows space in 
the DOS Compatibility Hole range, below 1MB, to be made 
available for additional PCI plug-in cards that need option 
ROM space. The disadvantage is that a popular memory 
manager, HIMEM.SYS, does not work properly when USB 
buffers are at top of memory AND the system has 64 KB or less 
of RAM. 
NIC Option ROM Download (enable/disable). The BIOS 
contains an embedded NIC option ROM to allow the unit to 
boot through the network to a PXE server. This is typically used 
to download a corporate image to a hard drive. The NIC 
option ROM takes up memory space below 1MB commonly 
referred to as DOS Compatibility Hole (DCH) space. This space 
is limited. This F10 option will allow users to disable the 
downloading of this embedded NIC option ROM thus giving 
more DCH space for additional PCI cards which may need 
option ROM space. The default will be to have the NIC option 
ROM enabled.

Onboard Devices Allows you to set resources for or disable onboard system 
devices (serial port, parallel port, or diskette controller).

PCI Devices Lists currently installed PCI devices and their IRQ settings. 
Allows you to reconfigure IRQ settings for these devices or to 
disable them entirely. These settings have no effect under an 
APIC-based operating system.

* Available on select models. 
**These options should be used by advanced users only.

Heading Option Description
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Advanced** 
(continued)

Bus Options* Allows you to enable or disable:
PCI bus mastering, which allows a PCI device to take control of 
the PCI bus.
PCI VGA palette snooping, which sets the VGA palette 
snooping bit in PCI configuration space; only needed when 
more than one graphics controller is installed.
PCI SERR# generation. 
ECC support allows hardware-based error correction for 
ECC-capable memories.

Device options Allows you to set: 
C1 Halt Disconnect.* Enabled by default on select models. 
Allows user to disconnect Front Side Bus during idle time to 
reduce power consumption.
Printer mode (bi-directional, EPP+ECP, output only).
Num Lock state at power-on (off/on).
PME (power management event) wakeup events 
(enable/disable).
Processor cache (enable/disable).
Hyper-Threading* (enable/disable).
ACPI S3* support (enable/disable). S3 is an ACPI sleep state 
that some add-in hardware options may not support.

✎ If the ACPI S3 support option is not presented, the other ACPI 
S3 options (ACPI S3 Video REPOST, AXPI S3 Hard disk 
Reset, and ACPI S3 PS2 Mouse Wakeup) will not be 
available. 

ACPI S3 Video REPOST* (enable/disable). This feature reruns 
the video option ROM on a boot from the S3 state.
ACPI S3 Hard Disk Reset* (enable/disable). Resets the hard 
disk on a boot from the S3 sleep state.
ACPI S3 PS2 Mouse Wakeup* (enable/disable). Allows the 
mouse to wake the system from the S3 sleep state.
AGP Aperture size* Allows you to specify the amount of system 
memory reserved for use by your graphics controller.
Monitor Tracking (enable/disable). Allows ROM to save 
monitor asset information.
Unique Sleep State Blink Patterns*. Allows you to choose an 
LED blink pattern that uniquely identifies each sleep state.
Frame Buffer Size* Allows you to specify amount of system 
memory dedicated to the embedded graphics frame buffer. The 
AUTO setting attempts to optimize the frame buffer size 
depending on the amount of total system memory.

PCI VGA 
Configuration

Displayed only if there are multiple PCI video adapters in the 
system. Allows you to specify which VGA controller will be the 
“boot” or primary VGA controller.

* Available on select models. 
**These options should be used by advanced users only.

Heading Option Description
2–12 338611-001 Service and Technical Reference Guide, xw3100



Computer Setup Utilities and Diagnostic Features
2.3 Diagnostics for Windows
The Diagnostics for Windows (DFW) utility is a component of Intelligent Manageability that 
allows you to view information about the hardware and software configuration of the workstation 
while running Microsoft Windows (Microsoft Windows 2000 and Microsoft Windows XP). It 
also allows you to perform hardware and software tests on the subsystems of the workstation.

When you invoke Diagnostics for Windows, the current configuration of the workstation is 
shown on the Overview screen. There is access from this screen to several categories of 
information about the workstation and the Test tab. The information in every screen of the utility 
can be saved to a file or printed.

✎ To test all subsystems, you must log in as the administrator. If you do not log in as the 
administrator, you will be unable to test some subsystems. The inability to test a subsystem will 
be indicated by an error message under the subsystem name in the Test window or by shaded 
check boxes that cannot be selected.

Use Diagnostics for Windows in the following instances to:

■ Determine if all the devices installed on the workstation are recognized by the system and 
functioning properly. Running tests is optional but recommended after installing or 
connecting a new device.

■ Third party devices not supported by HP may not be detected. Save, print, or display the 
information generated by the utility.

2.3.1 Detecting Diagnostics for Windows
Some workstations ship with the Diagnostics for Windows preloaded, but not preinstalled.

To determine whether Diagnostics for Windows is installed:

1. Access the location of the Diagnostics icons:

❏ In Windows 2000 Professional, select Start > Settings > Control Panel.

❏ In Windows XP Professional, select Start > Control Panel > Performance and 
Maintenance.

2. If icons for Configuration Record and Diagnostics for Windows are present, the Diagnostics 
for Windows utility is installed. If the icons are not present, the utility is either not preloaded 
or not installed. 

2.3.2 Installing Diagnostics for Windows 
If Diagnostics for Windows is not preloaded, you can download the Diagnostics for Windows 
SoftPaq from the following Web site:

http://www.hp.com/support/files

Once the software has been downloaded onto the hard drive it may be installed by performing 
these steps: 

1. Close all Windows applications.

2. Install the Diagnostics for Windows utility:

❏ In Windows XP, select Start > Setup Software icon. Select Diagnostics for Windows > 
Next button, then follow the instructions on the screen.
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❏ In Windows 2000, select the Setup Software icon on the Desktop > Diagnostics for 
Windows > Next button, then follow the instructions on the screen.

❏ In either Windows XP or Windows 2000, if the Setup Software icon is not on the 
Desktop or in the Start menu, run the Setup program from the C:\CPQAPPS\DIAGS 
directory or select Start > Run and type the following in the command line: 
C:\CPQAPPS\DIAGS\SETUP.

3. Click Next to install Diagnostics for Windows.

4. After the program has finished installing, you may be prompted to restart the workstation, or 
it may automatically restart. If prompted, click Finish to restart the workstation or Cancel to 
exit the program. You must restart the workstation to complete the installation of Diagnostics 
for Windows.

✎ If you want to upgrade an existing version of Diagnostics for Windows installed on the 
workstation, visit http://www.hp.com/support/files and click on an applicable product. Locate 
the desired software and download the latest version. Execute the downloaded file and select 
Repair to update the installed version. This will cause the new version to overwrite the old 
version.

2.3.3 Using Categories in Diagnostics for Windows 
To use categories:

1. Click Start > HP Information Center > Diagnostics for Windows. You can also select the 
Diagnostics for Windows icon, located in the Control Panel.

The screen displays the overview of the workstation hardware and software.

❏ In Windows 2000 Professional, select Start > Settings > Control Panel, then select 
Diagnostics for Windows.

❏ In Windows XP Professional, select Start > Control Panel > Performance and 
Maintenance, then select Diagnostics for Windows.

2. For specific hardware and software information, select a category from the Categories 
pull-down menu or the appropriate icon on the toolbar.

✎ As the cursor moves over the toolbar icons, the corresponding category name is displayed.

3. To display more detailed information in a selected category, click More in the Information 
Level box in the lower left corner of the window or click Level at the top of the screen and 
select More.

4. Review, print, and/or save this information as desired.

❏ To print the information, click File > Print. Select one of the following options: 
Detailed Report (All Categories), Summary Report (All Categories), or Current 
Category. Click OK to print the report you selected.

❏ To save the information, click File > Save As. Select one of the following options: 
Detailed Report (All Categories), Summary Report (All Categories), or Current 
Category. Click OK to save the report you selected.

5. To exit Diagnostics for Windows, click File, and then click Exit.
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Menu Bar—File, Categories, Navigation, Level, Tab, Help 
At the top of the Diagnostics for Windows screen is the Menu Bar consisting of six pull-down 
menus. Selecting an item will provide the following information on the system:

■ File—Save As, Print, Printer Setup, Exit

■ Categories

❏ System—System board, ROM, date, and time 

❏ Asset Control—Asset tag, system serial number, and processor 

❏ Input Devices—Keyboard, mouse, and joystick(s) 

❏ Communication—Ports 

❏ Storage—Storage drives

❏ Graphics—Graphics 

❏ Memory—System board and Windows memory 

❏ Multimedia—Optical storage (CD, DVD, and so on) and audio 

❏ Windows—Windows 

❏ Architecture—PCI Device 

❏ Resources—IRQ, I/O, and Memory Map 

❏ Health—Status of system temperature and hard drives

❏ Miscellaneous—CMOS, DMI, BIOS, System, Product Name, and Serial Number

■ Navigation—Previous Category (F5), Next Category (F6)

■ Level—Less (F7), More (F8) <information on the screen>

■ Tab

❏ Overview—Displays general information about the workstation. This window is 
displayed when first starting the utility. The left side of the window shows hardware 
information, while the right side shows software information.

❏ Test—Allows you to choose various parts of the system to test. You can also choose the 
type of test and testing mode.

❏ Status—Displays the status of each test in progress. You can cancel testing by clicking 
the Cancel Testing button.

❏ Log—Displays a log of tests for each device.

❏ Error—Displays any errors that occurred during device testing. The window lists the 
device being tested, the type and number of errors, and the error code.

■ Help—Contents, How to use Help, About
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2.3.4 Running Diagnostic Tests in Diagnostics for Windows
To run diagnostic tests:

1. Click Start > HP Information Center > Diagnostics for Windows. 

Alternately, you can access Diagnostics for Windows via the control panel.

The screen displays the overview of the workstation hardware and software. Five tabs are 
displayed below the row of icons: Overview, Test, Status, Log, and Error.

2. Click the Test tab, or click Tab at the top of the screen and select Test.

3. Select one of the following options:

❏ Quick Test—Runs a quick, general test on each device. Requires no user intervention if 
Unattended Mode is selected.

❏ Complete Test—Runs maximum testing of each device. The user can select Interactive 
Mode or Unattended Mode.

❏ Custom Test—Runs only the tests you select. To select specific devices or tests, find the 
device in the list, then select the check box beside each test. When selected, a red check 
mark is displayed in the box. Some tests selected may require user intervention.

✎ To test all subsystems, you must log in as the administrator. If you do not log in as the 
administrator, you will be unable to test some subsystems. The inability to test a subsystem will 
be indicated by an error message under the subsystem name in the Test window or by shaded 
boxes that cannot be checked.

4. Select Interactive Mode or Unattended Mode. In Interactive Mode, the diagnostic software 
will prompt you for input during tests that require it. Some tests require interaction and will 
display errors or halt testing if selected in conjunction with Unattended Mode.

❏ Interactive Mode provides maximum control over the testing process. You determine 
whether the test passed or failed and may be prompted to insert or remove devices.

❏ Unattended Mode does not display prompts. If errors are found, they are displayed when 
testing is complete.

5. Click the Begin Testing button at the bottom of the window. Test Status is displayed, 
showing the progress and result of each test. For more details on the tests run, click the Log 
tab or click Tab at the top of the screen and select Log.

6. To view a test report, select one of three tabs: 

❏ Status—Summarizes the tests run, passed, and failed during the current testing session.

❏ Log—Lists tests run on the system, the numbers of times each test has run, the number 
of errors found on each test, and the total run time of each test.

❏ Error—Lists all errors found on the workstation with their error codes.

7. To save a test report:

❏ Select the Log tab Save button to save a Log tab report.

❏ Select the Error tab Save button to save an Error tab report.
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8. To print a test report:

❏ If the report is on the Log tab, select File > Save As, then print the file from the selected 
folder.

❏ If the report is on the Error tab, select the Error tab Print button.

9. If errors are found, click the Error tab to display more detailed information and 
recommended actions. 

10. Click Print or save the error information for future reference.

11. To exit Diagnostics for Windows, click File > Exit.

2.4 Configuration Record
The Configuration Record utility is a windows-based information-gathering tool that gathers 
critical hardware and software information from various workstation subsystems. The 
information includes such things as the ROM, asset tag, processor, physical drives, PCI devices, 
memory, graphics, operating system version number, operating system parameters, and the 
operating system startup files to give a complete view of the workstation. Configuration Record 
provides a means for automatically identifying and comparing configuration changes, and has 
the ability to maintain a configuration history. The information can be saved as a history of 
multiple sessions.

This utility allows the resolution of problems without taking the workstation offline and assists in 
maximizing the workstation availability. The information obtained by the utility is useful in 
troubleshooting system problems, and streamlines the service process by enabling quick and easy 
identification of system configurations.

The utility displays it findings in a Now.log file. If the original Base.log file is present in the 
cpqdiags directory, the Base.log file is displayed next to the Now.log file in a split window with 
the differences between the two highlighted in the color red.

2.4.1 Installing Configuration Record 
The Configuration Record is part of Diagnostics for Windows and is automatically installed at 
the same time as Diagnostics for Windows.

2.4.2 Running Configuration Record
To run this program:

1. Click Start > HP Information Center > Configuration Record. 

Alternately, you can access Diagnostics for Windows via the control panel.

✎ The Configuration Record utility has two view options: Show Changed Items Only and Show 
All. The default view is Show Changed Items Only, therefore all the text is displayed in the 
color red since it shows only the differences. Switching to Show All displays the complete, 
comprehensive view of the system.

2. The default view is Show Changed Items Only. To view all the information gathered by 
Configuration Record, click View at the top of the window and select Show All, or click the 
Show All Items icon.

3. To save the information in the left or right window, select File > Save Window File and then 
select Left Window File or Right Window File.
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✎ Saving the configuration of the workstation periodically allows the user to keep a history of the 
configuration. This history may be useful to you in the future if the system ever encounters a 
problem that needs debugging.

4. To exit Configuration Record, click File, then click Exit.

2.5 Remote Diagnostics Enabling Agent
This utility provides a Web browser interface to Diagnostics for Windows. It enables remote 
control of the diagnostics and facilitates easy transfer of workstation information from remote 
machines to a service provider.

The Remote Diagnostics Enabling Agent captures hardware configuration and provides the 
ability to perform tests remotely to diagnose workstation problems. In addition, the Remote 
Diagnostics Enabling Agent identifies any workstation hardware device problems signaled by the 
HP Management Agents. These hardware devices are automatically selected for testing by the 
Remote Diagnostics Enabling Agent.

✎ The Remote Diagnostics Enabling Agent only works if Diagnostics for Windows is also 
installed. 
 
The Remote Diagnostics Enabling Agent is pre-loaded on some workstations and is available 
through a SoftPaq at http://www.hp.com under Support and Drivers.

2.5.1 Installing or Upgrading Remote Diagnostics 
Enabling Agent 

1. Visit http://www.hp.com/support/files and click on the applicable product.

2. Locate the appropriate software and download the latest version. 

3. Execute the downloaded file. If you are upgrading an existing version, select Repair for the 
new version to overwrite the old version.

2.5.2 Running the Remote Diagnostics Enabling Agent
1. Select the Remote Diagnostics icon located in the Control Panel.

✎ The Remote Diagnostics Enabling Agent allows you to run Diagnostic Test or the Configuration 
Record in a browser window. Both of these utilities can be run remotely or locally.

2. To exit Remote Diagnostics, click File and then click Close.
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2.6 Protecting the Software
To protect software from loss or damage, you should keep a backup copy of all system software, 
applications, and related files stored on the hard drive. See the operating system or backup utility 
documentation for instructions on making backup copies of data files.

2.7 Restoring the Software 
The Windows operating system and software can be restored to its original state by using the 
Restore CD. See the Restore CD for complete instructions on using this feature.
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3
Desktop Management

HP Intelligent Manageability provides standards-based solutions for managing and controlling 
desktops, workstations, and notebook PCs in a networked environment. 

The key capabilities and features of desktop management are:

■ Initial configuration and deployment

■ Remote system installation

■ Software updating and management

■ ROM flash

■ Asset tracking and security

■ Fault notification and recovery

✎ Support for specific features described in this guide may vary by model or software version.

3.1 Initial Configuration and Deployment
HP workstations come with a preinstalled system software image. After a brief software 
“unbundling” process, the workstation is ready to be used.

A customized software image may be deployed by: 

■ Installing additional software applications after unbundling the preinstalled software image.

■ Using software deployment tools, such as Altiris Deployment Solutions, to replace the 
preinstalled software with a customized software image.

■ Using a disk cloning process to copy the contents from one hard drive to another.

The best deployment method depends on your information technology environment and 
processes. The PC Deployment section of the Solutions and Services Web site 
(http://www.hp.com/go/pcsolutions) provides information to help you select the best 
deployment method.

The Restore Plus! CD, ROM-based setup, and ACPI hardware provide further assistance with 
recovery of system software, configuration management and troubleshooting, and power 
management.
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3.2 Remote System Installation
Remote System Installation allows you to start and set up your system using the software and 
configuration information located on a network server by initiating the Preboot Execution 
Environment (PXE). The Remote System Installation feature is usually used as a system setup 
and configuration tool, and can be used for the following tasks:

■ Formatting a hard drive.

■ Deploying a software image on one or more new PCs.

■ Remotely updating the system BIOS in flash ROM. See Section 3.3.8, “Remote ROM 
Flash.”

■ Configuring the system BIOS settings.

To initiate Remote System Installation, press F12 when the F12 = Network Service Boot 
message appears in the lower-right corner of the HP logo screen. Follow the instructions on the 
screen to continue the process. The default boot order is a BIOS configuration setting that can be 
changed to always attempt to PXE boot.

3.3 Software Updating and Management
HP provides several tools for managing and updating software on desktops and workstations— 
Altiris PC Transplant Pro; HP Client Manager Software, an Altiris solution; System Software 
Manager; HP Proactive Notification, and ActiveUpdate.

3.3.1 HP Client Manager Software
HP Client Manager Software (HP CMS) tightly integrates HP Intelligent Manageability 
technology within Altiris to provide superior hardware management capabilities for HP access 
devices that include:

■ Detailed views of hardware inventory for asset management

■ PC health check monitoring and diagnostics

■ Proactive notification of changes in your hardware environment

■ Web-accessible reporting of business critical details such as machines with thermal 
warnings, memory alerts, and more

■ Remote updating of system software such as device drivers and ROM BIOS

For more information on the HP Client Manager, visit http://www.hp.com/go/easydeploy.

3.3.2 Altiris Solutions
HP Client Manager provides centralized hardware management of HP client devices for all IT 
lifecycle areas.

■ Inventory and Asset Management

❏ SW license compliance

❏ PC tracking and reporting

❏ Lease contract, fixing asset tracking
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■ Deployment and Migration

❏ Windows 2000/XP migration

❏ System deployment

❏ Personality migrations

■ Help Desk and Problem Resolution

❏ Managing help desk tickets

❏ Remote troubleshooting

❏ Remote problem resolution

❏ Client disaster recovery

■ Software and Operations Management

❏ Ongoing desktop management

❏ HP system SW deployment

❏ Application self-healing

On selected desktop and notebook models, an Altiris management agent is included as part of the 
factory loaded image. This agent enables communication with the Altiris development Solution 
which can be used to complete new hardware deployment or personality migration to a new OS 
using easy-to-follow wizards. Altiris solutions provide easy-to-use software distribution 
capabilities. When used in conjunction with System Software Manager (Section 3.3.4), or the HP 
Client Manager, administrators can also update ROM BIOS and device driver software from a 
central console.

For more information, visit http://www.hp.com/go/easydeploy

3.3.3 Altiris PC Transplant Pro
Altiris PC Transplant Pro allows you to preserve old settings, preferences, and data and migrate 
them to the new environment quickly and easily. 

For more information, visit http://www.hp.com/go/easydeploy.

3.3.4 System Software Manager
System Software Manager (SSM) lets you update system-level software on multiple systems 
simultaneously. When executed on a PC client system, SSM detects both hardware and software 
versions, then updates the appropriate software from a central repository, also known as a file 
store. Driver versions that are supported by SSM are denoted with a special icon on the driver 
download Web site and on the Support Software CD. To download the utility or to obtain more 
information on SSM, visit http://www.hp.com/go/ssm.

3.3.5 Product Change Notification (PCN)
This feature is available on select models. 

The HP Proactive Notification program uses the Subscriber's Choice Web site to proactively and 
automatically:

■ Send you Product Change Notification (PCN) emails informing you of hardware and 
software changes to most workstations, up to 60 days in advance.
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■ Send you email containing Customer Bulletins, Customer Advisories, Customer Notes, 
Security Bulletins, and Driver alerts for most workstations.

You create your own profile to ensure that you only receive the information relevant to your IT 
environment. To learn more about HPPN and create your custom profile, visit 
http://www.hp.com/go/pcn

3.3.6 ActiveUpdate
ActiveUpdate is a client-based application from HP. The ActiveUpdate client uses your 
user-defined profile to proactively and automatically download software updates to a server 
repository for most HP workstations.

To learn more about ActiveUpdate, download the application, and create your custom profile, 
visit http://www.compaq.com/activeupdate.

3.3.7 ROM Flash
The workstation comes with a reprogrammable flash ROM (read only memory). By establishing 
a setup password in Computer Setup (F10) Utility, you can protect the ROM from being 
unintentionally updated or overwritten. This is important to ensure the operating integrity of the 
workstation. Should you need or want to upgrade your ROM, you may:

■ Order an upgraded ROMPaq™ diskette from HP.

■ Download the latest ROMPaq images from http://www.hp.com/support.

Ä
CAUTION: For maximum ROM protection, be sure to establish a setup password. The setup password 
prevents unauthorized ROM upgrades. System Software Manager allows the system administrator to set 
the setup password on one or more PCs simultaneously. For more information, visit 
http://www.hp.com/go/ssml.

3.3.8 Remote ROM Flash
Remote ROM Flash allows the system administrator to safely upgrade the ROM on remote HP 
workstations directly from the centralized network management console. Enabling the system 
administrator to perform this task remotely, on multiple workstations, results in a consistent 
deployment of and greater control over HP PC ROM images over the network. 

✎ The workstation must be powered on, or turned on through Remote Wakeup, to take advantage of 
Remote ROM Flash.

For more information on Remote ROM Flash, refer to the HP Client Manager Software or 
System Software Manager at http://www.hp.com/go/easydeploy.

3.3.9 FailSafe Boot Block ROM
The FailSafe Boot Block ROM allows for system recovery in the unlikely event of a ROM flash 
failure, for example, if a power failure were to occur during a ROM upgrade. The Boot Block is a 
flash-protected section of the ROM that checks for a valid system ROM flash when power to the 
system is turned on.
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■ If the system ROM is valid, the system starts normally.

■ If the system ROM fails the validation check, the FailSafe Boot Block ROM provides 
enough support to start the system from a ROMPaq diskette, which will program the system 
ROM with a valid image.

When the bootblock detects an invalid system ROM, The System Power LED blinks RED 8 
times, one every second, followed by a 2 second pause. Also 8 simultaneous beeps will be heard. 
A Boot Block recovery mode message is displayed on the screen (some models). 

To recover the system after it enters Boot Block recovery mode, complete the following steps:

1. If there is a diskette in the diskette drive, remove the diskette and turn off the power.

2. Insert a ROMPaq diskette into the diskette drive.

3. Turn on power to the system.

4. If no ROMPaq diskette is found, you will be prompted to insert one and restart the 
workstation.

5. If a setup password has been established, the Caps Lock light will turn on and you will be 
prompted to enter the password.

6. Enter the setup password.

7. If the system successfully starts from the diskette and successfully reprograms the ROM, 
then the three keyboard lights will turn on. A rising tone series of beeps also signals 
successful completion.

8. Remove the diskette and turn the power off.

9. Turn the power on again to restart the workstation.

The following table lists the various keyboard light combinations used by the Boot Block ROM 
(when a PS/2 keyboard is attached to the workstation), and explains the meaning and action 
associated with each combination.

Keyboard Light Combinations Used by Boot Block ROM 

Failsafe Boot 
Block Mode

Keyboard 
LED Color

Keyboard 
LED Activity State/Message

Num Lock Green On ROMPaq diskette not present, is bad, or 
drive not ready.

Caps Lock Green On Enter password.

Num, Caps, 
Scroll Lock

Green Blink on in 
sequence, 
one-at-a-time— 
N,C,SL

Keyboard locked in network mode.

Num, Caps, 
Scroll Lock

Green On Boot Block ROM Flash successful. Turn 
power off, then on to reboot.

✎ Diagnostic lights do not flash on USB keyboards.
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3.3.10 Replicating Your Setup
This procedure gives an administrator the ability to quickly and easily copy one setup 
configuration to other workstations of the same model. To replicate the setup:

1. Access the Computer Setup Utilities (F10) menu. 

2. Click File > Save to Diskette. Follow the instructions on the screen.

✎ This requires a diskette drive or a supported USB flash media device, such as DiskOnKey.

3. To replicate the configuration, click File > Restore from Diskette, and follow the 
instructions on the screen.

System Software Manager (SSM) may also be used to distribute setup configurations to multiple 
workstations. For more information, see http://www.hp.com/go/ssm.

3.3.11 Dual-State Power Button
With Advanced Configuration and Power Interface (ACPI) enabled for Windows 2000 and 
Windows XP, the power button can function either as an on/off switch or as a suspend button. 
The suspend feature does not completely turn off power, but instead causes the workstation to 
enter a low-power standby. This allows you to quickly power down without closing applications 
and to quickly return to the same operational state without any data loss.

To change the power button’s configuration, complete the following steps:

1. In Windows 2000, left click on the Start Button, then select Settings > Control Panel > 
Power Options.

In Windows XP, left click on the Start Button, then select Control Panel > Performance 
and Maintenance > Power Options.

2. In the Power Options Properties, select the Advanced tab.

3. In the Power Button section, select the desired power button setting.

After configuring the power button to function as a suspend button, press the power button to put 
the system in a very low power state (suspend). Press the button again to quickly bring the system 
out of suspend to full power status. To completely turn off all power to the system, press and hold 
the power button for four seconds.

Ä
CAUTION: Do not use the power button to turn off the workstation unless the system is not responding; 
turning off the power without operating system interaction could cause damage to or loss of data on the 
hard drive.

3.3.12 Energy Star
HP products purchased with the Energy Star configuration are compliant with the U.S. 
Environmental Protection Agency (EPA) Energy Star Computers Program. The EPA Energy Star 
configuration does not imply endorsement by the EPA. As an Energy Star Partner, HP has 
determined that products with the Energy Star configuration meet the Energy Star guidelines for 
energy efficiency. 
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The Energy Star Computers Program was created by the EPA to promote energy efficiency and 
reduce air pollution through more energy-efficient equipment in homes, offices, and factories. 
HP products achieve this by reducing the power consumption when not being used. Instructions 
for using the energy saving features of the workstation are located in the “Power Management” 
section below.

The power management feature is compatible with operating systems and environments that 
support APM1.2. This means that users in those environments will not be disconnected from the 
network during the low-power operating state.

The Power Management feature, when used in conjunction with an external Energy Star 
compliant monitor, will support the power-down features of the monitor. The Power 
Management feature allows an external monitor to go into low-power mode when the energy 
save timeout occurs.

Ä
CAUTION: Using the Energy Save Monitor feature with non-Energy Star compliant monitors may cause 
video distortion when the Energy Save timeout occurs.

If you purchased your workstation with Energy Star-enabled, your system will go into Standby (a 
power management feature) after 15 or 20 minutes of inactivity. To wake from Standby, press a 
key on the keyboard or move the mouse.

To view, modify or enable/disable the power management feature, refer to the “Power 
Management” section below. 

✎ Should you have to restore the operating system, your Energy Star settings will need to be reset. 
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3.3.13 Power Management
Power Management is a feature that saves energy by shutting down certain components of the 
workstation when they are not in use, saving energy without having to shut down the 
workstation.

With Advanced Configuration and Power Interface (ACPI) enabled for Windows 2000 and 
Windows XP, timeouts (the period of inactivity allowed before shutting down these components) 
can be enabled, customized, or disabled using the operating system.

1. In Windows 2000, left click on the Start Button, then select Settings > Control Panel > 
Power Options.

In Windows XP, left click on the Start Button, then select Control Panel > Performance 
and Maintenance > Power Options.

2. In the Power Options Properties, select the Power Schemes tab.

3. Select the desired power scheme settings.

Use Display Properties to establish, modify, or disable Power Management settings for the 
monitor. To access Display Properties, right click on the Windows Desktop, then choose 
Properties.

3.3.14 World Wide Web Site
When making the transition to new or revised operating systems, it is important to implement the 
support software designed for that operating system. If you plan to run a version of Microsoft 
Windows that is different from the version included with your workstation, you must install 
corresponding device drivers and utilities to ensure that all features are supported and 
functioning properly.

HP has made the task of locating, accessing, evaluating, and installing the latest support software 
easier. You can download the software from http://www.hp.com/support. The Web site contains 
the latest device drivers, utilities, and flashable ROM images needed to run the latest Microsoft 
Windows operating system on your HP workstation.

3.3.15 Building Blocks and Partners
HP management solutions integrate with other systems management applications, and are based 
on industry standards, such as:

■ Desktop Management Interface (DMI) 2.0

■ Wake on LAN Technology

■ ACPI

■ SMBIOS

■ Pre-boot Execution (PXE) support
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3.4 Asset Tracking and Security
Asset tracking features incorporated into the workstation provide key asset tracking data that can 
be managed using HP Insight Manager, HP Client Manager or other system management 
applications. Seamless, automatic integration between asset tracking features and these products 
enables you to choose the management tool that is best suited to your environment and to 
leverage your investment in existing tools. 

HP also offers several solutions for controlling access to valuable components and information. 
Security features such as the Smart Cover Sensor and the Smart Cover Lock, available on select 
models, help to prevent unauthorized access to the internal components of the workstation. By 
disabling parallel, serial, or USB ports, or by disabling removable media boot capability, you can 
protect valuable data assets. Memory Change and Smart Cover Sensor alerts can be 
automatically forwarded to system management applications to deliver proactive notification of 
tampering with a workstation’s internal components.

✎ The Smart Cover Sensor and the Smart Cover Lock are available as options on select systems.

Use the following utilities to manage security settings on your HP workstation:

■ Locally, using the Computer Setup Utilities. 

■ Remotely, using HP Client Manager or System Software Manager. This software enables the 
secure, consistent deployment and control of security settings from a simple command-line 
utility.

The following table and sections refer to managing security features of your workstation locally 
through the Computer Setup Utilities (F10). 

Security Features Overview  

Feature Purpose How It Is Established

Removable Media Boot 
Control

Prevents booting from the 
removable media drives.

From the Computer Setup 
Utilities (F10) menu.

Serial, Parallel, USB, or 
Infrared Interface Control

Prevents transfer of data 
through the integrated serial, 
parallel, USB (universal serial 
bus), or infrared interface.

From the Computer Setup 
Utilities (F10) menu.

Power-On Password Prevents use of the workstation 
until the password is entered. 
This can apply to both initial 
system startup and restarts.

From the Computer Setup 
Utilities (F10) menu.

Setup Password Prevents reconfiguration of the 
workstation (use of the 
Computer Setup Utilities) until 
the password is entered.

From the Computer Setup 
Utilities (F10) menu.

DriveLock Prevents unauthorized access 
to the data on specific hard 
drives. This feature is available 
on select models only.

From the Computer Setup 
Utilities (F10) menu.

✎
Support for security features may vary depending on your specific workstation configuration.
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Smart Cover Sensor Indicates that workstation 
cover or side panel has been 
removed. Can be set to require 
the setup password to restart 
the workstation, after the cover 
or side panel has been 
removed. Refer to the 
Hardware Reference Guide on 
the Documentation Library CD 
for more information about this 
feature. This feature is 
available on select models 
only.

From the Computer Setup 
Utilities (F10) menu.

Master Boot Record Security May prevent unintentional or 
malicious changes to the 
Master Boot Record of the 
current bootable disk, and 
provides a means of 
recovering the “last known 
good” MBR.

From the Computer Setup 
Utilities (F10) menu.

Memory Change Alerts Detects when memory 
modules have been added, 
moved, or removed; notifies 
user and system administrator.

For information on enabling 
Memory Change Alerts, 
refer to the online Intelligent 
Manageability Guide.

Ownership Tag Displays ownership 
information, as defined by the 
system administrator, during 
system startup (protected by 
setup password).

From the Computer Setup 
Utilities (F10) menu.

Cable Lock Provision Inhibits access to the interior of 
the workstation to prevent 
unwanted configuration 
changes or component 
removal. Can also be used to 
secure the workstation to a 
fixed object to prevent theft.

Install a cable lock to secure 
the workstation to a fixed 
object.

Security Loop Provision Inhibits access to the interior of 
the workstation to prevent 
unwanted configuration 
changes or component 
removal.

Install a lock in the security 
loop to prevent unwanted 
configuration changes or 
component removal.

Security Features Overview  (Continued)

Feature Purpose How It Is Established

✎
Support for security features may vary depending on your specific workstation configuration.
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3.4.1 Password Security
The power-on password prevents unauthorized use of the workstation by requiring entry of a 
password to access applications or data each time the workstation is turned on or restarted. The 
setup password specifically prevents unauthorized access to Computer Setup, and can also be 
used as an override to the power-on password. That is, when prompted for the power-on 
password, entering the setup password instead will allow access to the workstation.

A network-wide setup password can be established to enable the system administrator to log in to 
all network systems to perform maintenance without having to know the power-on password, 
even if one has been established.

3.4.2 Establishing a Setup Password Using Computer Setup
Establishing a setup password through Computer Setup prevents reconfiguration of the 
workstation (use of the Computer Setup (F10) utility) until the password is entered.

1. Turn on or restart the workstation. If you are in Windows, click Start > Shut Down > 
Restart the Computer.

2. Press the F10 key as soon as the monitor light turns green. Press Enter to bypass the title 
screen, if necessary.

✎ If you do not press the F10 key at the appropriate time, you must turn the workstation off, then 
on again, and press the F10 key again to access the utility.

3. Select Security, then select Setup Password and follow the instructions on the screen.

4. Before exiting, click File > Save Changes and Exit.

3.4.3 Establishing a Power-On Password Using Computer Setup
Establishing a power-on password through Computer Setup prevents access to the workstation 
when power is turned on, unless the password is entered. When a power-on password is set, 
Computer Setup presents Password Options under the Security menu. Password options include 
Password Prompt on Warm Boot. When Password Prompt on Warm Boot is enabled, the 
password must also be entered each time the workstation is rebooted. 

1. Turn on or restart the workstation. If you are in Windows, click Start > Shut Down > 
Restart the Computer.

2. Press the F10 key as soon as the monitor light turns green. Press Enter to bypass the title 
screen, if necessary.

✎ If you do not press the F10 key at the appropriate time, you must turn the workstation off, then 
on again, and press the F10 key again to access the utility.

3. Select Security, then Power-On Password and follow the instructions on the screen.

4. Before exiting, click File > Save Changes and Exit.

Entering a Power-On Password
To enter a power-on password, complete the following steps:

1. Turn on or restart the workstation. If you are in Windows, click Start > Shut Down > 
Restart the Computer. 
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2. When the key icon appears on the monitor, type your current password, then press Enter.

✎ Type carefully; for security reasons, the characters you type do not appear on the screen.

If you enter the password incorrectly, a broken key icon appears. Try again. After three 
unsuccessful tries, you must turn off the workstation, then turn it on again before you can 
continue.

Entering a Setup Password
If a setup password has been established on the workstation, you will be prompted to enter it each 
time you run Computer Setup.

1. Turn on or restart the workstation. If you are in Windows, click Start > Shut Down > 
Restart the Computer. 

2. Press the F10 key as soon as the monitor light turns green.

✎ If you do not press the F10 key at the appropriate time, you must turn the workstation off, then 
on again, and press the F10 key again to access the utility.

3. When the key icon appears on the monitor, type the setup password, then press the Enter 
key.

✎ Type carefully; for security reasons, the characters you type do not appear on the screen.

If you enter the password incorrectly, a broken key icon appears. Try again. After three 
unsuccessful tries, you must turn off the workstation, then turn it on again before you can 
continue.

Changing a Power-On or Setup Password
1. Turn on or restart the workstation. If you are in Windows, click Start > Shut Down > 

Restart the Computer. To change the setup password, run Computer Setup.

2. When the key icon appears, type your current password, a slash (/) or alternate delimiter 
character, your new password, another slash (/) or alternate delimiter character, and your new 
password again as shown: 
current password/new password/new password

✎ Type carefully; for security reasons, the characters you type do not appear on the screen.

3. Press the Enter key.

The new password takes effect the next time you turn on the workstation.

✎ Refer to the “National Keyboard Delimiter Characters” section in this chapter for information 
about the alternate delimiter characters. 
The power-on password and setup password may also be changed using the Security options in 
Computer Setup.

Deleting a Power-On or Setup Password
1. Turn on or restart the workstation. If you are in Windows, click Start > Shut Down > 

Restart the Computer. To delete the setup password, run Computer Setup.
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2. When the key icon appears, type your current password followed by a slash (/) or alternate 
delimiter character as shown: 
current password/

3. Press the Enter key.

✎ Refer to “National Keyboard Delimiter Characters” for information about the alternate delimiter 
characters. The power-on password and setup password may also be changed using the Security 
options in Computer Setup.
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National Keyboard Delimiter Characters
Each keyboard is designed to meet country-specific requirements. The syntax and keys that you 
use for changing or deleting your password depend on the keyboard that came with your 
workstation.

Clearing Passwords 
If you forget your password, you cannot access the workstation. Refer to the “Troubleshooting” 
section of this guide for instructions on clearing passwords.

3.4.4 DriveLock
DriveLock is an industry-standard security feature that prevents unauthorized access to the data 
on specific hard drives. DriveLock has been implemented as an extension to Computer Setup. It 
is only available on certain systems and only when DriveLock-capable hard drives are detected. 

DriveLock is intended for HP customers for whom data security is the paramount concern. For 
such customers, the cost of the hard drive and the loss of the data stored on it is inconsequential 
when compared with the damage that could result from unauthorized access to its contents. In 
order to balance this level of security with the practical need to accommodate a forgotten 
password, the HP implementation of DriveLock employs a two-password security scheme. One 
password is intended to be set and used by a system administrator while the other is typically set 
and used by the end-user. There is no “back-door” that can be used to unlock the drive if both 
passwords are lost. Therefore, DriveLock is most safely used when the data contained on the 
hard drive is replicated on a corporate information system or is regularly backed up.

In the event that both DriveLock passwords are lost, the hard drive is rendered unusable. For 
users who do not fit the previously defined customer profile, this may be an unacceptable risk. 
For users who do fit the customer profile, it may be a tolerable risk given the nature of the data 
stored on the hard drive.

Using DriveLock
The DriveLock option appears under the Security menu in Computer Setup. The user is 
presented with options to set the master password or to enable DriveLock. A user password must 
be provided in order to enable DriveLock. Since the initial configuration of DriveLock is 

National Keyboard Delimiter Characters
Arabic / Greek - Russian /
Belgian = Hebrew . Slovakian -
BHCSY* - Hungarian - Spanish -
Brazilian / Italian - Swedish/Finnish /
Chinese / Japanese / Swiss -
Czech - Korean / Taiwanese /
Danish - Latin American - Thai /
French ! Norwegian - Turkish .
French Canadian é Polish - U.K. English /
German - Portuguese - U.S. English /
* For Bosnia-Herzegovina, Croatia, Slovenia, and Yugoslavia
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typically performed by a system administrator, a master password should be set first. HP 
encourages system administrators to set a master password whether they plan to enable 
DriveLock or keep it disabled. This will give the administrator the ability to modify DriveLock 
settings if the drive is locked in the future. Once the master password is set, the system 
administrator may enable DriveLock or choose to keep it disabled.

If a locked hard drive is present, POST will require a password to unlock the device. If a 
power-on password is set and it matches the device’s user password, POST will not prompt the 
user to re-enter the password. Otherwise, the user will be prompted to enter a DriveLock 
password. Either the master or the user password may be used. Users will have two attempts to 
enter a correct password. If neither attempt succeeds, POST will continue but the drive will 
remain inaccessible.

DriveLock Applications
The most practical use of the DriveLock security feature is in a corporate environment where a 
system administrator provides users with multibay hard drives for use in some workstations. The 
system administrator would be responsible for configuring the multibay hard drive which would 
involve, among other things, setting the DriveLock master password. In the event that the user 
forgets the user password or the equipment is passed on to another employee, the master 
password can always be used to reset the user password and regain access to the hard drive.

HP recommends that corporate system administrators who choose to enable DriveLock also 
establish a corporate policy for setting and maintaining master passwords. This should be done to 
prevent a situation where an employee intentionally or unintentionally sets both DriveLock 
passwords before leaving the company. In such a scenario, the hard drive would be rendered 
unusable and require replacement. Likewise, by not setting a master password, system 
administrators may find themselves locked out of a hard drive and unable to perform routine 
checks for unauthorized software, other asset control functions, and support.

For users with less stringent security requirements, HP does not recommend enabling DriveLock. 
Users in this category include personal users or users who do not maintain sensitive data on their 
hard drives as a common practice. For these users, the potential loss of a hard drive resulting 
from forgetting both passwords is much greater than the value of the data DriveLock has been 
designed to protect. Access to Computer Setup and DriveLock can be restricted through the 
Setup password. By specifying a Setup password and not giving it to end users, system 
administrators are able to restrict users from enabling DriveLock.
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3.5 Smart Cover Sensor (Optional)
Smart Cover Sensor is a combination of hardware and software technology that can alert you 
when the workstation cover or side panel has been removed. There are three levels of protection, 
as described in the following table. 

Setting the Smart Cover Sensor Protection Level
To set the Smart Cover Sensor protection level, complete the following steps:

1. Turn on or restart the workstation. If you are in Windows, click Start > Shut Down > 
Restart the Computer.

2. Press the F10 key as soon as the monitor light turns green. Press Enter to bypass the title 
screen, if necessary.

✎ If you do not press the F10 key at the appropriate time, you must turn the workstation off, then 
on again, and press the F10 key again to access the utility.

3. Select Security, then Smart Cover, and follow the instructions on the screen.

4. Before exiting, click File > Save Changes and Exit.

Smart Cover Lock (Optional)
The Smart Cover Lock is a software-controllable cover lock featured on select HP workstations. 
This lock prevents unauthorized access to the internal components. Workstations ship with the 
Smart Cover Lock in the unlocked position.

Ä
CAUTION: For maximum cover lock security, be sure to establish a setup password. The setup password 
prevents unauthorized access to the Computer Setup utility.

Smart Cover Sensor Protection Levels

Level Setting Description

Level 0 Disabled Smart Cover Sensor is disabled (default).

Level 1 Notify User When the workstation is restarted, the 
screen displays a message indicating that 
the workstation cover or side panel has 
been removed.

Level 2 Setup Password When the workstation is restarted, the 
screen displays a message indicating that 
the workstation cover or side panel has 
been removed. You must enter the setup 
password to continue.

✎ These settings can be changed using Computer Setup. 
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Locking the Smart Cover Lock
To activate and lock the Smart Cover Lock, complete the following steps:

1. Turn on or restart the workstation. If you are in Windows, click Start > Shut Down > 
Restart the Computer.

2. Press the F10 key as soon as the monitor light turns green. Press Enter to bypass the title 
screen, if necessary.

✎ If you do not press the F10 key at the appropriate time, you must turn the workstation off, then 
on again, and press the F10 key again to access the utility.

3. Select Security, then select Smart Cover and the Locked option.

4. Before exiting, click File > Save Changes and Exit.

Unlocking the Smart Cover Lock
1. Turn on or restart the workstation. If you are in Windows, click Start > Shut Down > 

Restart the Computer.

2. Press the F10 key as soon as the monitor light turns green. Press Enter to bypass the title 
screen, if necessary.

✎ If you do not press the F10 key at the appropriate time, you must turn the workstation off, then 
on again, and press the F10 key again to access the utility.

3. Select Security > Smart Cover > Unlocked.

4. Before exiting, click File > Save Changes and Exit.

Using the Smart Cover FailSafe Key
If you enable the Smart Cover Lock and cannot enter your password to disable the lock, you will 
need a Smart Cover FailSafe Key to open the workstation cover. You will need the key in any of 
the following circumstances:

■ Power outage

■ Startup failure

■ PC component failure (such as processor or power supply)

■ Forgotten password

Ä
CAUTION: The Smart Cover FailSafe Key is a specialized tool available from HP. Be prepared; order 
this key before you need one (Tamper-resistant wrench PN 166527-001 or tamper-resistant bits PN 
166527-002).

3.5.1 Master Boot Record Security
The Master Boot Record (MBR) contains information needed to successfully boot from a disk 
and to access the data stored on the disk. Master Boot Record Security may prevent unintentional 
or malicious changes to the MBR, such as those caused by some viruses or by the incorrect use of 
certain disk utilities. It also allows you to recover the “last known good” MBR, should changes to 
the MBR be detected when the system is restarted.
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To enable MBR Security, complete the following steps:

1. Turn on or restart the workstation. If you are in Windows, click Start > Shut Down > 
Restart the Computer.

2. Press the F10 key as soon as the monitor light turns green. Press Enter to bypass the title 
screen, if necessary.

✎ If you do not press the F10 key at the appropriate time, you must turn the workstation off, then 
on again, and press the F10 key again to access the utility.

3. Select Security > Master Boot Record Security > Enabled.

4. Select Security > Save Master Boot Record.

5. Before exiting, click File > Save Changes and Exit.

When MBR Security is enabled, the BIOS prevents any changes being made to the MBR of the 
current bootable disk while in MS-DOS or Windows Safe Mode. 

✎ Most operating systems control access to the MBR of the current bootable disk; the BIOS cannot 
prevent changes that may occur while the operating system is running.

Each time the workstation is turned on or restarted, the BIOS compares the MBR of the current 
bootable disk to the previously saved MBR. If changes are detected and if the current bootable 
disk is the same disk from which the MBR was previously saved, the following message is 
displayed:

1999—Master Boot Record has changed.

Press any key to enter Setup to configure MBR Security.

Upon entering Computer Setup, you must

■ Save the MBR of the current bootable disk;

■ Restore the previously saved MBR; or

■ Disable the MBR Security feature.

You must know the setup password, if one exists.

If changes are detected and if the current bootable disk is not the same disk from which the MBR 
was previously saved, the following message is displayed:

2000—Master Boot Record Hard Drive has changed.

Press any key to enter Setup to configure MBR Security.

Upon entering Computer Setup, you must 

■ Save the MBR of the current bootable disk; or

■ Disable the MBR Security feature.

You must know the setup password, if one exists.

In the unlikely event that the previously saved MBR has been corrupted, the following message is 
displayed:

1998—Master Boot Record has been lost.

Press any key to enter Setup to configure MBR Security.
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Upon entering Computer Setup, you must 

■ Save the MBR of the current bootable disk; or

■ Disable the MBR Security feature.

You must know the setup password, if one exists.

3.5.2 Before You Partition or Format the Current Bootable Disk
Ensure that MBR Security is disabled before you change partitioning or formatting of the current 
bootable disk. Some disk utilities, such as FDISK and FORMAT, attempt to update the MBR. If 
MBR Security is enabled when you change partitioning or formatting of the disk, you may 
receive error messages from the disk utility or a warning from MBR Security the next time the 
workstation is turned on or restarted. To disable MBR Security, complete the following steps:

1. Turn on or restart the workstation. If you are in Windows, click Start > Shut Down > 
Restart the Computer.

2. Press the F10 key as soon as the monitor light turns green. Press Enter to bypass the title 
screen, if necessary.

✎ If you do not press the F10 key at the appropriate time, you must turn the workstation off, then 
on again, and press the F10 key again to access the utility.

3. Select Security > Master Boot Record Security > Disabled.

4. Before exiting, click File > Save Changes and Exit.

3.5.3 Cable Lock Provision
The rear panel of the workstation accommodates a cable lock so that the workstation can be 
physically secured to a work area.

For illustrated instructions, please see the “Removal and Replacement” Chapter.

3.6 Fault Notification and Recovery
Fault Notification and Recovery features combine innovative hardware and software technology 
to prevent the loss of critical data and minimize unplanned downtime.

When a fault occurs, the workstation displays a Local Alert message containing a description of 
the fault and any recommended actions. You can then view current system health by using the HP 
Client Manager Software. If the workstation is connected to a network managed by HP Insight 
Manager, HP Client Manager Software, or other system management applications, the 
workstation also sends a fault notice to the network management application.

3.6.1 Drive Protection System
The Drive Protection System (DPS) is a diagnostic tool built into the hard drives installed in 
select HP workstations. DPS is designed to help diagnose problems that might result in 
unwarranted hard drive replacement. 

When HP workstations are built, each installed hard drive is tested using DPS, and a permanent 
record of key information is written onto the drive. Each time DPS is run, test results are written 
to the hard drive. Your service provider can use this information to help diagnose conditions that 
caused you to run the DPS software. 
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3.6.2 Surge-Tolerant Power Supply
An integrated surge-tolerant power supply provides greater reliability when the workstation is hit 
with an unpredictable power surge. This power supply is rated to withstand a power surge of up 
to 2000 volts without incurring any system downtime or data loss.

3.6.3 Thermal Sensor
The thermal sensor is a hardware and software feature that tracks the internal temperature of the 
workstation. This feature displays a warning message when the normal range is exceeded, which 
gives you time to take action before internal components are damaged or data is lost.
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4
Identifying the Chassis, Routine Care, and 

Disassembly Preparation

This chapter provides general service information for the workstation. Adherence to the 
procedures and precautions described in this chapter is essential for proper service.

Ä
CAUTION: When the workstation is plugged into an AC power source voltage is always applied to the 
system board. You must disconnect the power cord from the power source before opening the workstation 
to prevent system board or component damage. 

4.1 Small Form Factor (SFF)

✎ If the computer is in the desktop configuration, ensure at least 6 inches (15.24 cm) of space on all 
sides of the computer remains clear and free of obstructions.

✎ Chassis color scheme may differ than the one shown above.
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4.2 Electrostatic Discharge Information
A sudden discharge of static electricity from your finger or other conductor can destroy 
static-sensitive devices or microcircuitry. Often the spark is neither felt nor heard, but damage 
occurs. An electronic device exposed to electrostatic discharge (ESD) may not appear to be 
affected at all and can work perfectly throughout a normal cycle. The device may function 
normally for a while, but it has been degraded in the internal layers, reducing its life expectancy.

Networks built into many integrated circuits provide some protection, but in many cases, the 
discharge contains enough power to alter device parameters or melt silicon junctions.

4.2.1 Generating Static
The following table shows that:

■ Different activities generate different amounts of static electricity. 

■ Static electricity increases as humidity decreases. 

✎ 700 volts can degrade a product.

4.2.2 Preventing Electrostatic Damage to Equipment 
Many electronic components are sensitive to ESD. Circuitry design and structure determine the 
degree of sensitivity. The following packaging and grounding precautions are necessary to 
prevent damage to electric components and accessories.

■ To avoid hand contact, transport products in static-safe containers such as tubes, bags, or 
boxes.

■ Protect all electrostatic parts and assemblies with conductive or approved containers or 
packaging.

■ Keep electrostatic sensitive parts in their containers until they arrive at static-free stations.

■ Place items on a grounded surface before removing them from their container.

■ Always be properly grounded when touching a sensitive component or assembly.

■ Avoid contact with pins, leads, or circuitry.

■ Place reusable electrostatic-sensitive parts from assemblies in protective packaging or 
conductive foam.

Relative Humidity

Event 55% 40% 10%

Walking across carpet 
Walking across vinyl floor 
Motions of bench worker 
Removing DIPs* from plastic tube

7,500 V 
3,000 V 
400 V 
400 V

15,000 V 
5,000 V 
800 V 
700 V

35,000 V 
12,000 V 
6,000 V 
2,000 V

Removing DIPs* from vinyl tray 
Removing DIPs* from Styrofoam 
Removing bubble pack from PCB 
Packing PCBs in foam-lined box

2,000 V 
3,500 V 
7,000 V 
5,000 V

4,000 V 
5,000 V 
20,000 V 
11,000 V

11,500 V 
14,500 V 
26,500 V 
21,000 V

*These are then multi-packaged inside plastic tubes, trays, or Styrofoam.
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4.2.3 Personal Grounding Methods and Equipment
Use the following equipment to prevent static electricity damage to equipment:

■ Wrist straps are flexible straps with a maximum of one-megohm ± 10% resistance in the 
ground cords. To provide proper ground, a strap must be worn snug against bare skin. The 
ground cord must be connected and fit snugly into the banana plug connector on the 
grounding mat or workstation.

■ Heel straps/Toe straps/Boot straps can be used at standing workstations and are 
compatible with most types of shoes or boots. On conductive floors or dissipative floor mats, 
use them on both feet with a maximum of one-megohm ± 10% resistance between the 
operator and ground.

4.2.4 Grounding the Work Area
To prevent static damage at the work area, use the following precautions:

■ Cover the work surface with approved static-dissipative material. Provide a wrist strap 
connected to the work surface and properly grounded tools and equipment.

■ Use static-dissipative mats, foot straps, or air ionizers to give added protection.

■ Handle electrostatic sensitive components, parts, and assemblies by the case or PCB 
laminate. Handle them only at static-free work areas.

■ Turn off power and input signals before inserting and removing connectors or test 
equipment.

■ Use fixtures made of static-safe materials when fixtures must directly contact dissipative 
surfaces.

■ Keep work area free of nonconductive materials such as ordinary plastic assembly aids and 
Styrofoam.

■ Use field service tools, such as cutters, screwdrivers, and vacuums, that are conductive.

4.2.5 Recommended Materials and Equipment
Materials and equipment that are recommended for use in preventing static electricity include:

■ Antistatic tape

■ Antistatic smocks, aprons, or sleeve protectors

■ Conductive bins and other assembly or soldering aids

■ Conductive foam

■ Conductive tabletop workstations with ground cord of one-megohm +/- 10% resistance

■ Static-dissipative table or floor mats with hard tie to ground

■ Field service kits

Static Shielding Protection Levels

Method Voltage

Antistatic plastic 
Carbon-loaded plastic 
Metallized laminate

1,500 
7,500  
15,000
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■ Static awareness labels

■ Wrist straps and footwear straps providing one-megohm +/- 10% resistance

■ Material handling packages

■ Conductive plastic bags

■ Conductive plastic tubes

■ Conductive tote boxes

■ Opaque shielding bags

■ Transparent metallized shielding bags

■ Transparent shielding tubes

4.3 Routine Care

4.3.1 General Cleaning Safety Precautions
1. Never use solvents or flammable solutions to clean the workstation.

2. Never immerse any parts in water or cleaning solutions; apply any liquids to a clean cloth 
and then use the cloth on the component.

3. Always unplug the workstation when cleaning with liquids or damp cloths.

4. Always unplug the workstation before cleaning the keyboard, mouse, or air vents.

5. Disconnect the keyboard before cleaning it.

6. Wear safety glasses equipped with side shields when cleaning the keyboard.

4.3.2 Cleaning the Workstation Case
Follow all safety precautions in Section 4.3.1 before cleaning the workstation.

To clean the workstation case, follow the procedures described below:

■ To remove light stains or dirt, use plain water with a clean, lint-free cloth or swab.

■ For stronger stains, use a mild dishwashing liquid diluted with water. Rinse well by wiping it 
with a cloth or swab dampened with clear water.

■ For stubborn stains, use isopropyl (rubbing) alcohol. No rinsing is needed as the alcohol will 
evaporate quickly and not leave a residue.

■ After cleaning, always wipe the unit with a clean, lint-free cloth.

■ Occasionally clean the air vents on the workstation. Lint and other foreign matter can block 
the vents and limit the airflow.
4–4 338611-001 Service and Technical Reference Guide, xw3100



Identifying the Chassis, Routine Care, and Disassembly Preparation
4.3.3 Cleaning the Keyboard
Follow all safety precautions in Section 4.3.1 before cleaning the keyboard.

To clean the tops of the keys or the keyboard body, follow the procedures described in Section 
4.3.2.

When cleaning debris from under the keys, review all rules in Section 4.3.1before following 
these procedures:

Ä
CAUTION: Use safety glasses equipped with side shields before attempting to clean debris from under 
the keys. 

■ Visible debris underneath or between the keys may be removed by vacuuming or shaking.

■ Canned, pressurized air may be used to clean debris from under the keys. Caution should be 
used as too much air pressure can dislodge lubricants applied under the wide keys.

■ If you remove a key, use a specially designed key puller to prevent damage to the keys. This 
tool is available through many electronic supply outlets.

Ä
CAUTION: Never remove a wide leveled key (like the space bar) from the keyboard. If these keys are 
improperly removed or installed, the keyboard may not function properly.

■ Cleaning under a key may be done with a swab moistened with isopropyl alcohol and 
squeezed out. Be careful not to wipe away lubricants necessary for proper key functions. Use 
tweezers to remove any fibers or dirt in confined areas. Allow the parts to air dry before 
reassembly.

4.3.4 Cleaning the Monitor
■ Wipe the monitor screen with a clean cloth moistened with water or with a towelette 

designed for cleaning monitors. Do not use sprays or aerosols directly on the screen; the 
liquid may seep into the housing and damage a component. Never use solvents or flammable 
liquids on the monitor.

■ To clean the monitor body follow the procedures in Section 4.3.2.    

4.3.5 Cleaning the Mouse
Before cleaning the mouse, ensure that the power to the workstation is turned off.

■ Clean the mouse ball by first removing the retaining plate and the ball from the housing. Pull 
out any debris from the ball socket and wipe the ball with a clean, dry cloth before 
reassembly. 

■ To clean the mouse body, follow the procedures in Section 4.3.
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4.4 Service Considerations
Listed below are some of the considerations that you should keep in mind during the disassembly 
and assembly of the workstation.

4.4.1 Power Supply Fan
The power supply fan is a variable-speed fan based on the temperature in the power supply.

Ä
CAUTION: The cooling fan is off only when the workstation is turned off or the power cable has been 
disconnected. 
 
The cooling fan is always on when the workstation is either in the “On,” “Standby,” or “Suspend” modes. 
 
You must disconnect the power cord from the power source before opening the workstation to prevent 
system board or component damage. 

4.4.2 Tools and Software Requirements
To service the workstation, you need the following:

■ Torx T-15 screwdriver (Compaq screwdriver with bits, PN 161946-001)

■ Torx T-15 screwdriver with small diameter shank (for certain front bezel removal)

■ Flat-bladed screwdriver (may sometimes be used in place of the Torx screwdriver)

■ Diagnostics software

■ Compaq tamper-resistant T-15 wrench (Smart Cover FailSafe Key, PN 166527-001) or 
Compaq tamper-resistant bits (Smart Cover FailSafe Key, PN 166527-002)

4.4.3 Screws
The screws used in the workstation are not interchangeable. They may have standard or metric 
threads and may be of different lengths. If an incorrect screw is used during the reassembly 
process, it can damage the unit. HP strongly recommends that all screws removed during 
disassembly be kept with the part that was removed, then returned to their proper locations.

✎ Metric screws have a black finish. 
U.S. screws have a silver finish.

✎ As each subassembly is removed from the workstation, it should be placed away from the work 
area to prevent damage.
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4.4.4 Cables and Connectors
Most cables used throughout the unit are flat, flexible cables. These cables must be handled with 
care to avoid damage. Apply only the tension required to seat or unseat the cables during 
insertion or removal from the connector. Handle cables by the connector whenever possible. In 
all cases, avoid bending or twisting the cables, and ensure that the cables are routed in such a way 
that they cannot be caught or snagged by parts being removed or replaced.

Ä
CAUTION: When servicing this workstation, ensure that cables are placed in their proper location 
during the reassembly process. Improper cable placement can damage the workstation. 

4.4.5 Hard Drives
Handle hard drives as delicate, precision components, avoiding all physical shock and vibration. 
This applies to failed drives as well as replacement spares.

■ If a drive must be mailed, place the drive in a bubble-pack mailer or other suitable protective 
packaging and label the package “Fragile: Handle With Care.”

■ Do not remove hard drives from the shipping package for storage. Keep hard drives in their 
protective packaging until they are actually mounted in the CPU.

■ Avoid dropping drives from any height onto any surface.

■ If you are inserting or removing a hard drive, turn off the workstation. Do not remove a hard 
drive while the workstation is on or in standby mode.

■ Before handling a drive, ensure that you are discharged of static electricity. While handling a 
drive, avoid touching the connector. For more information about preventing electrostatic 
damage, refer to Section 4.2, “Electrostatic Discharge Information.”

■ Do not use excessive force when inserting a drive.

■ Avoid exposing a hard drive to liquids, temperature extremes, or products that have magnetic 
fields such as monitors or speakers.

4.4.6 Lithium Coin Cell Battery
The battery that comes with the workstation provides power to the real-time clock and has a 
minimum lifetime of about three years. 

See the appropriate removal and replacement chapter for the chassis you are working on in this 
guide for instructions on the replacement procedures. 

Å
WARNING: This workstation contains a lithium battery. There is a risk of fire and chemical burn if the 
battery is handled improperly. Do not disassemble, crush, puncture, short external contacts, dispose in 
water or fire, or expose it to temperatures higher than 140ºF (60ºC).

Ä
CAUTION: Batteries, battery packs, and accumulators should not be disposed of together with the 
general household waste. 
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Removal and Replacement Procedures

Adherence to the procedures and precautions described in this chapter is essential for proper 
service. After completing all necessary removal and replacement procedures, run the Diagnostics 
utility to verify that all components operate properly.

✎ Not all features listed in this guide are available on all workstations.

5.1 Preparation for Disassembly 
See Chapter 4, 'Identifying the Chassis, Routine Care, and Disassembly Preparation' for initial 
procedures.

1. Remove/disengage any security devices that prohibit opening the workstation (Section 5.2 
and 5.4).

2. Close any open software applications.

3. Exit the operating system.

4. Remove any media such as a diskette or compact disc from the workstation.

5. Turn off the workstation and any peripheral devices that are connected to it.

Ä
CAUTION: Turn off the workstation before disconnecting any cables.

Ä
CAUTION: Regardless of the power-on state, voltage is always present on the system board as long as 
the system is plugged into an active AC outlet. In some systems the cooling fan is on even when the 
workstation is in the “Standby,” or “Suspend” modes. The power cord should always be disconnected 
before servicing a unit.

6. Disconnect the power cord from the electrical outlet and then from the workstation.

7. Disconnect all peripheral device cables from the workstation.

✎ During disassembly, label each cable as you remove it, noting its position and routing. Keep all 
screws with the units removed.

Ä
CAUTION: The screws used in the workstation are of different thread sizes and lengths; using the wrong 
screw in an application may damage the unit.
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5.2 Unlocking the Smart Cover Lock 
If you have locked the Smart Cover Lock use Computer Setup to unlock the lock. Refer to the 
Desktop Management Guide on the Documentation Library CD for more information about the 
Smart Cover Lock.

If you cannot access Computer Setup to unlock the cover you will need to remove the locking 
solenoid by using the Smart Cover FailSafe Key (Spare part number 166527-001 or 
166527-002). Once the solenoid has been deactivated or removed the access panel can be 
removed.

The Smart Cover FailSafe Key will be needed in any of the following circumstances:

■ Power outage

■ Startup failure

■ Processor or power supply failure

■ Lost password

1. Using the Smart Cover FailSafe Key, remove the two tamper-proof screws that secure the Smart 
Cover Lock to the inside of the chassis.

2. Remove the workstation access panel (Section 5.5).

To reattach the Smart Cover Lock, position the lock so that the printed circuit board it is attached 
to points down when the workstation is oriented as shown. Then, secure the lock in place with the 
two tamper-proof screws.
5–2 338611-001 Service and Technical Reference Guide, xw3100



Removal and Replacement Procedures
5.3 Hood Sensor 
1. Prepare the workstation for disassembly (Section 5.1).

2. Remove the workstation access panel (Section 5.5).

3. Remove the front bezel (Section 5.6).

4. Raise the drive cage to its upright position 1.

5. Slide the hood sensor switch towards the inside of the workstation 2. 

6. Disconnect the hood sensor cable from the system board 3.

To install the hood sensor, reverse the removal procedure.
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5.4 External Security Devices

5.4.1 Cable Lock 
The cable lock may be used to secure the workstation access panel to the chassis and, at the same 
time, secure the workstation to a fixed object. 

✎ The workstation is cable-lock compatible, but HP does not offer the lock as an after market 
product.
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5.4.2 Padlock 
A padlock may be used by itself to secure the access panel to the workstation chassis. A padlock 
may also be used with a security cable to secure the workstation to a fixed object.
I
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5.5 Workstation Access Panel
1. Prepare the workstation for disassembly (Section 5.1).

Ä
CAUTION: Before removing the workstation access panel, ensure that the workstation is turned off and 
that the power cord is disconnected from the electrical outlet.

2. Pull up and hold open the latch on the top of the workstation 1.

3. Slide the workstation cover 2 back about 0.5inch (1.3 cm), then lift it off the unit.

To install the workstation cover, reverse the removal procedure.
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5.6 Front Bezel 
1. Prepare the workstation for disassembly (Section 5.1).

2. Remove the workstation access panel (Section 5.5).

3. Pull up on the three release tabs 1 on the top of the bezel, then pull the front bezel away 
from the chassis 2.

To reinstall the front bezel, reverse the removal procedure 
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5.7 Front Drive Bezels 
1. Prepare the workstation for disassembly (Section 5.1).

2. Remove the workstation access panel (Section 5.5).

3. Remove the front bezel (Section 5.6).

5.7.1 Diskette Drive Bezel or Bezel Blank 
Press the large retaining tab 1 on the left side of the bezel insert to the left and push the cover out 
of the front bezel 2. 

To install a bezel or a bezel blank, reverse the removal procedure.
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5.8 Memory 

Ä
CAUTION: The memory module sockets have gold metal contacts. When upgrading the memory, it is 
important to use memory modules with gold metal contacts to prevent corrosion and/or oxidation 
resulting from having incompatible metals in contact with each other.

Ä
CAUTION: Static electricity can damage the electronic components of the workstation or optional cards. 
Before beginning these procedures, ensure that you are discharged of static electricity by briefly touching 
a grounded metal object. Refer to Chapter 4 for more information.

Ä
CAUTION: When handling a memory module, be careful not to touch any of the contacts. Doing so 
may damage the module.

1. If you have locked the Smart Cover Lock, use Computer Setup to unlock the lock 
(Section 5.2).

2. Prepare the workstation for disassembly (Section 5.1).

3. Remove the workstation access panel (Section 5.5).

Å
WARNING: To reduce risk of personal injury from hot surfaces, allow the internal system components to 
cool before touching.

4. Open both latches of the memory module socket 1, and insert the memory module into the 
socket 2. Begin by installing a module into the socket nearest the preinstalled module, and 
install the modules following the numerical order of the sockets.

✎ A memory module can be installed in only one way. Match the notch on the module with the tab 
on the memory socket. 

5. Push the module down into the socket, ensuring that the module is fully inserted and 
properly seated. Make sure the latches are in the closed position 3.

6. Repeat steps 4 and 5 for any additional modules that you want to install.
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The workstation automatically recognizes the additional memory when the workstation is turned 
on.

To reassemble the workstation, reverse the removal procedure.

✎ If you normally lock the Smart Cover Lock, use Computer Setup to relock the lock and enable 
the Smart Cover Sensor.

For technical information on memory modules, refer to Appendix F, “Memory.”

5.9 Expansion Card Cage
1. If you have locked the Smart Cover Lock, use Computer Setup to unlock the lock 

(Section 5.2).

2. Prepare the workstation for disassembly (Section 5.1).

3. Remove the workstation access panel (Section 5.5).

4. Disconnect all cables attached to the expansion cards.

5. Grasp the expansion card cage by the green labels (the cage in the workstation has two spots 
marked 1) and pull it straight up from the chassis.

To install the card cage, reverse the removal procedures.
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5.9.1 Riser Card 
1. If you have locked the Smart Cover Lock, use Computer Setup to unlock the lock 

(Section 5.2).

2. Prepare the workstation for disassembly (Section 5.1).

3. Remove the workstation access panel (Section 5.5).

4. Remove the expansion card cage (Section 5.9).

5. Remove the three screws that secure the riser card to the expansion card cage, then remove 
the card.

To install the riser card, reverse the removal procedure.
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5.9.2 Expansion Card 
1. If you have locked the Smart Cover Lock, use Computer Setup to unlock the lock 

(Section 5.2).

2. Prepare the workstation for disassembly (Section 5.1).

3. Remove the workstation access panel (Section 5.5).

4. Remove the expansion card cage (Section 5.9).

5. If you are installing a card for the first time, go to step 6. 
If you are removing an existing card, open the release latch as described in step 6 then go to 
step 8.

6. If you are installing an expansion card in a vacant socket, release the slot cover retention 
latch 1 that secures the PCI slot covers by rotating the latch outwards (the latch in the 
workstation has a green label on it marked 2).

7. Remove the slot cover by sliding it out 2.
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8. To remove an expansion card, hold the card at each end and carefully rock it back and forth 
until the connectors pull free from the socket. Lift the expansion card straight up to release it 
from the carrier. Be sure not to scrape the card against other components.

5.9.3 AGP Card

Some graphics cards (such as the nVIDIA Quadro4 400 NVS) will require you to remove the 
diskette drive (or hard drive, if installed) from bay 1 to allow enough remove to install the 
graphics card.

1. If you have locked the Smart Cover Lock, use Computer Setup to unlock the lock 
(Section 5.2).

2. Prepare the workstation for disassembly (Section 5.1).

3. Remove the workstation access panel (Section 5.5).

4. Lift the green lever to unlock the AGP card.
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5. If installing an AGP card for the first time, go to step 6. 
If removing an AGP card, go to step 9.

6. Remove the slot cover.

7. Slide the bracket on the end of the expansion card down into the slot on the back of the 
chassis and press the card down firmly into the socket on the system board. 

✎ When you install an expansion card, make sure you press firmly on the card so that the whole 
connector seats properly in the expansion card socket on the system board.

8. Close the expansion slot retention bracket by rotating it toward the chassis 1 and pressing 
down on the thumb tabs 2 so that they snap firmly into place.

9. To remove an AGP card, pull the retention arm away from the socket then carefully rock the 
card back and forth until the connectors pull free from the socket. Lift the expansion card 
straight up then pull it in toward the center of the chassis to release it from the chassis frame. 
Be sure not to scrape the card against other components.

10. Store the removed card in anti-static packaging.

Ä
CAUTION: After removing an expansion card, you must replace it with a new card or cover the open 
slot (for example, with a metal slot cover or a piece of duct tape) for proper cooling of internal 
components during operation.

11. Connect external cables to the installed card and internal cables to the system board as 
needed. 

12. Replace the workstation cover.

13. If you normally lock the Smart Cover Lock, use Computer Setup to relock the lock and 
enable the Smart Cover Sensor.

14. Reconfigure the workstation, if necessary. 
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5.10 Drives
The workstation supports up to three drives.

This Section describes the procedure for replacing or upgrading the storage drives. A Torx T-15 
screwdriver is needed to remove and install the guide screws on a drive.

Ä
CAUTION: Make sure personal files on the hard drive are backed up to an external storage device 
before removing the hard drive. Failure to do so will result in data loss. After replacing the primary hard 
drive, you will need to run the Restore Plus! CD to load the Compaq factory-installed files.

5.10.1 Extra Screws
The following spare guide screws are included with the chassis (located inside) for installing new 
drives:

■ Four 6-32 screws for installing an extra hard drive

■ Four M3 screws for installing an optical or diskette drive

5.10.2 Drive Positions 
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To verify the type and size of the storage device installed in the workstation, run Computer 
Setup.

5.10.3 Optical Drive 

Ä
CAUTION: All removable media should be taken out of the drives before removing the drive from the 
workstation.

✎ An optical drive is a CD-ROM, CD-RW, DVD-ROM, Combo, or DVD+RW drive.

1. If you have locked the Smart Cover Lock, use Computer Setup to unlock the lock 
(Section 5.2).

2. Prepare the workstation for disassembly (Section 5.1).

3. Remove the workstation access panel (Section 5.5). 

4. Remove the front bezel (Section 5.6).

5. Raise the Easy Access drive bay (bay 2 area) to the upright position. 

6. Disconnect the audio, signal, and drive power cables from the drive. The other end of the 
cables should remain connected to the system board.

7. Return the Easy Access drive bay to the down position.

Drive Positions

Item Description Item Description

1 One standard 3.5-inch, one-third 
height bay (1.44-MB diskette drive 
shown)*

3 Internal 3.5-inch, one-third height 
bay for hard drive

2 5.25-inch drive bay for optional 
drives.

*If the workstation has a 1.44-MB diskette drive installed, it will be configured with a diskette 
drive bezel as shown in the illustration. If the workstation contains an empty 3.5-inch drive bay, 
then a bezel blank will be installed on the workstation instead. If you do not have a drive in this 
slot, you may choose to install a 3.5-inch device (such as a diskette drive or hard drive) later on. 
However, to install a 3.5-inch device other than a diskette drive or hard drive, you must order the 
3.5-inch device bezel to provide proper air flow within the chassis.
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8. Push the drive release latch 1 toward the rear of the chassis and hold.

9. Slide the drive 2 toward the front of the drive cage, then lift the drive out of the workstation.

To replace the drive:

1. Install two guide screws in the lower holes on each side of the drive. 

Ä
CAUTION: Use only 3/16-inch or 5-mm long screws as guide screws. Longer screws can damage the 
internal components of the drive.

✎ When replacing the drive, transfer the four screws from the old drive to the new one. The screws 
take the place of drive rails. You will need a Torx T-15 screwdriver to remove and re-install the 
guide screws.
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2. Position the guide screws on the drive into the J-slots in the drive bay 1. Then, slide the drive 
towards the rear of the workstation 2.

✎ The drive release latch automatically locks in place when installing a drive.

3. Raise the Easy Access drive bay to the upright position and connect the flat ribbon cable and 
audio cable to the system board.

4. Connect the power cable, flat ribbon cable, and audio cable to the rear of the optical drive.

5. Return the Easy Access drive bay to the down position. Be sure not to pinch the cables in the 
chassis when lowering the Easy Access drive bay.

6. Replace the front bezel and workstation access panel.
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The system automatically recognizes the drive and reconfigures the workstation.

Ä
CAUTION: When servicing the workstation, ensure that cables are placed in their proper locations 
during the reassembly process. Improper cable placement can damage the workstation.

5.10.4 External 3.5-inch Drive 
1. If you have locked the Smart Cover Lock, use Computer Setup to unlock the lock 

(Section 5.2).

2. Prepare the workstation for disassembly (Section 5.1).

3. Remove the workstation access panel (Section 5.5). 

4. Remove the front bezel (Section 5.6).

5. Raise the Easy Access drive bay to the upright position.

6. Disconnect the audio, signal, and drive power cables from the drive. The other end of the 
cables should remain connected to the system board.

7. Return the Easy Access drive bay to the down position.

8. Push the drive release latch 1 toward the rear of the chassis and hold.

9. Slide the drive 2 toward the front of the drive cage, then lift the drive out of the workstation.

✎ When replacing the drive, transfer the four screws from the old drive to the new one. The screws 
take the place of drive rails. You will need a Torx T-15 screwdriver to remove and re-install the 
guide screws.
Service and Technical Reference Guide, xw3100 338611-001 5–19



Removal and Replacement Procedures
✎ The guide screws on a 3.5-inch diskette drive 1 are placed closer together than on the hard 
drive 2.

10. Insert the rear screws of the hard drive 1 into the rear J-slots. Slide the drive 2 toward the 
back of the drive cage until the front screws are aligned with the front J-slots. Then lower the 
front of the drive. Continue to slide the drive all the way back until it locks into place.

✎ If replacing a diskette drive, all guide screws (front and rear) will line up on the J-slots. Insert the 
guide screws into the J-slots, then slide the drive toward the back of the drive cage until it locks 
into place.

11. Connect the power and data cables.

12. Replace the front bezel and workstation access panel.
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5.10.5 Primary Hard Drive 
1. If you have locked the Smart Cover Lock, use Computer Setup to unlock the lock 

(Section 5.2).

2. Prepare the workstation for disassembly (Section 5.1).

3. Remove the workstation access panel (Section 5.5).

4. Remove the front bezel (Section 5.6).

5. Raise the Easy Access drive bay to the upright position.

6. Disconnect the power cable and signal cable from the back of the drive.

Disconnecting Cables from the Hard Drive
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7. Press and hold the drive release latch 1. 

8. Slide the drive to the right of the bay 2, then pull the drive from the bay 3.

To replace the hard drive, reverse the above procedure.

✎ When replacing the hard drive, transfer the four screws from the old drive to the new one. The 
screws take the place of drive rails. You will need a Torx T-15 screwdriver to remove and 
re-install the guide screws.
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5.11 Front I/O Devices 
1. Prepare the workstation for disassembly (Section 5.1).

2. Remove the workstation access panel (Section 5.5).

3. Disconnect the two I/O device cables from the system board: the front USB cable pair and 
the front audio cable.

4. Remove the power supply from the chassis (Section 5.17).

5. From the inside of the chassis, remove the two screws that secure the I/O device to the 
chassis 1, then pull the device into the chassis 2 to free it from its mount. 

To install the housing assembly, reverse the removal procedures.
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5.12 Power Switch Assembly 
1. Prepare the workstation for disassembly (Section 5.1).

2. Remove the workstation access panel (Section 5.5).

3. Disconnect the power switch/LED cable from the system board. 

4. Carefully cut the cable tie that secures the power switch cable to the power supply cable 
cable bundle. 

Ä
CAUTION: Be careful when cutting the cable tie not to cut any cables. 

5. Squeeze the switch holder retaining clips together at the front of the chassis 1 and push the 
switch assembly out of the chassis 2.

To install the power switch assembly, reverse the removal procedure. 
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5.13 System Board 
1. Prepare the workstation for disassembly (Section 5.1).

2. Remove the workstation access panel (Section 5.5).

3. Remove all PCI expansion boards (Section 5.9).

4. Remove the AGP graphics card (Section 5.9).

5. Disconnect all cables connected to the system board, noting their location for reinstallation.

6. Compress the system board tray handle 1 to release the latch and slide the system board tray 
towards the front of the workstation 2 to free it from the back of the chassis.

To install the system board with its tray, reverse the removal procedures.
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5.14 Battery
The battery that comes with this workstation provides power to the real-time clock and has a 
lifetime of about three years. When replacing the battery, use a battery equivalent to the battery 
originally installed on the workstation. The workstation comes with a 3-volt lithium coin cell 
battery.

✎ The lifetime of the lithium battery can be extended by plugging the workstation into a live AC 
wall socket. The lithium battery is only used when the workstation is NOT connected to AC 
power.

Å
WARNING: This workstation contains an internal lithium manganese dioxide battery. There is a risk of fire 
and burns if the battery is not handled properly. To reduce the risk of personal injury:
■ Do not attempt to recharge the battery.
■ Do not expose to temperatures higher than 140°F (60°C) 
■ Do not disassemble, crush, puncture, short external contacts, or dispose of in fire or 

water.
■ Replace the battery only with the HP/Compaq spare designated for this product.

Ä
CAUTION: Before replacing the battery, it is important to back up the workstation CMOS settings. 
When the battery is removed or replaced, the CMOS settings will be cleared. Refer to the 
Troubleshooting Guide for information on backing up the CMOS settings.

N
Batteries, battery packs, and accumulators should not be disposed of together with the general 
household waste. In order to forward them to recycling or proper disposal, please use the public 
collection system or return them to HP/Compaq, their authorized partners, or their agents.

Ä
CAUTION: Static electricity can damage the electronic components of the workstation or optional 
equipment. Before beginning these procedures, ensure that you are discharged of static electricity by 
briefly touching a grounded metal object.

1. Prepare the workstation for disassembly (Section 5.1).

2. Remove the workstation access panel (Section 5.5).

✎ It may be necessary to remove an expansion card to gain access to the battery.

3. Locate the battery and battery holder on the system board.

4. Carefully pull the cable bundle out of the way to access the battery.

5. Depending on the type of battery holder on your system board, complete the following 
instructions to replace the battery:
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5.14.1 Type 1 Battery Holder
1. Lift the battery out of its holder.

2. Slide the replacement battery into position, positive side up.

3. The battery holder automatically secures the battery in the proper position.

4. Replace the workstation cover or access panel.

5. Plug in the workstation and turn on power to the workstation.

6. Reset the date and time, your passwords, and any special system setups, using Computer 
Setup. 
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5.14.2 Type 2 Battery Holder
1. To release the battery from its holder, squeeze the metal clamp that extends above one edge 

of the battery.

2. When the battery pops up, lift it out.

3. To insert the new battery, slide one edge of the replacement battery under the holder’s lip 
with the positive side up. Push the other edge down until the clamp snaps over the other edge 
of the battery.

✎ After the battery has been replaced, use the following steps to complete this procedure.

4. Replace the workstation cover or access panel.
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5. Plug in the workstation and turn on power to the workstation.

Reset the date and time, your passwords, and any special system setups, using Computer Setup. 

5.15 Processor and Heatsink 
1. Prepare the workstation for disassembly (Section 5.1).

2. Remove the workstation access panel (Section 5.5).

3. Lift up the lever that secure the fan to the heatsink 1 and rotate the fan up 2.

4. Release the two latch locks 3 and raise the legs that secure the latches to the base of heatsink 
mount 4.

5. Tap the heatsink to check its temperature. If it is cool enough to handle, then proceed.

6. Twist the heatsink slightly to break the bond between it and the processor, the lift the 
heatsink from the processor 5. 

7. Rotate the ZIF socket handle to its fully open position 6 and remove the processor from the 
socket 7. 

To install the processor and heatsink:

1. Insert the processor into the ZIF socket.

2. Press down on the processor while rotating and locking the ZIF socket handle in place.

3. Refresh the thermal grease between the heatsink and processor if necessary.

4. Install the heatsink and latch it in place.

5. Connect the heatsink fan control to the system board.

6. Replace the access panel and reconnect the workstation.
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Removal and Replacement Procedures
5.16 Speaker 

To install the speaker:

1. Prepare the workstation for disassembly (Section 5.1).

2. Remove the workstation access panel (Section 5.5).

3. Rotate the drive cage to its upright position.

4. Remove the expansion card cage (Section 5.9).

5. Disconnect the speaker wire from the system board.

6. Carefully cut the cable tie that secures the speaker cable to the power supply cable bundle. 

Ä
CAUTION: Be careful when cutting the cable tie not to cut any cables. 

7. Remove the power supply from the chassis (Section 5.17).

8. Remove the two screws that secure the speaker to the chassis.

9. Slide the speaker towards the rear of the chassis and down to remove it.

To install the speaker, reverse the removal procedures.

Sound power level LWAd (B)

Operation: Hard Drive/48X CD-ROM 4.2/5.4 Bels

Stand-by/Idle: 3.9 Bels

Sound pressure level dB

Operation: Hard Drive/48X CD-ROM 29/44 dBA

Stand-by/Idle: 26 dBA
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Removal and Replacement Procedures
5.17 Power Supply 

Å
WARNING: Voltage is always present on the system board when the workstation is plugged into an 
active AC outlet. To avoid possible personal injury and damage to the equipment the power cord should 
be disconnected from the workstation and/or the AC outlet before opening the workstation.

1. Prepare the workstation for disassembly (Section 5.1).

2. Remove the workstation access panel (Section 5.5).

3. Rotate the drive cage to its upright position.

4. Remove the expansion card cage (Section 5.9).

5. Carefully cut the cable tie that secures the power supply cable bundle to the power switch 
cable, the speaker cable, and the front I/O cable. 

6. Disconnect all power cables from the mass storage devices and from the system board.

7. Remove the three screws that secure the rear chassis panel to the chassis 1, the pull the rear 
chassis panel straight back 2 to remove it from the chassis. 

8. Slide the power supply out the back of the workstation 3.

To install the power supply, reverse the removal procedure.
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A
Connector Pin Assignments

Enhanced Keyboard
Connector and Icon Pin Signal

1 
2 
3

Data 
Unused 
Ground

4 
5 
6

+5 VDC 
Clock 
Unused

Mouse
Connector and Icon Pin Signal

1 
2 
3

Data 
Unused 
Ground

4 
5 
6

+5 VDC 
Clock 
Unused

Ethernet BNC
Connector and Icon Pin Signal

1 (Center) Data

2 (Shield) Ground

Ethernet RJ-45
Connector and Icon Pin Signal

1 
2 
3 
4

(+) Transmit Data 
(-) Transmit Data 
(+) Receive Data 
Unused

5 
6 
7 
8

Unused 
(-) Receive Data 
Unused 
Unused
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Connector Pin Assignments
Ethernet AUI

Connector and Icon

Pin Signal Pin Signal

1 
2 
3 
4

Ground 
Negative AUI Differential Collision 
Positive AUI Differential Collision 
Negative AUI Differential Transmit

9 
10 
11 
12

Positive AUI Differential Receive 
+12V 
Ground 
Ground

5 
6 
7 
8

Positive AUI Differential Transmit 
Ground 
Ground 
Negative AUI Differential Receive

13 
14 
15 
16

Unused 
Unused 
Unused 
Unused

Parallel Interface

Connector and Icon

Pin Signal Pin Signal Pin Signal

1 
2 
3

Strobe 
Data Bit 0 
Data Bit 1

7 
8 
9

Data Bit 5 
Data Bit 6 
Data Bit 7

13 
14 
15

Select 
Auto Linefeed 
Error

4 
5 
6

Data Bit 2 
Data Bit 3 
Data Bit 4

10 
11 
12

Acknowledge 
Busy 
Paper End

16 
17 
18-25

Initialize Printer 
Select IN 
Signal Ground

Serial Interface
Connector and Icon Pin Signal

1 
2 
3

Carrier Detect 
Receive Data 
Transmit Data

4 
5 
6

Data Terminal Ready 
Signal Ground 
Data Set Ready

7 
8 
9

Request to Send 
Clear to Send 
Ring Indicator
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Connector Pin Assignments
USB
Connector and Icon Pin Signal

1 
2 
3 
4

+5 VDC 
- Data 
+ Data 
Ground

Microphone
Connector and Icon (1/8” miniphone) Pin Signal

1 (Tip) Audio

2 (Ring) Power

3 (Shield) Ground

Headphone
Connector and Icon (1/8” miniphone) Pin Signal

1 (Tip) Audio_Left

2 (Ring) Audio_Right

3 (Shield) Ground

Line-In Audio
Connector and Icon (1/8” miniphone) Pin Signal

1 (Tip) Audio_In_Left

2 (Ring) Audio_In_Right

3 (Shield) Ground

Line-Out Audio
Connector and Icon (1/8” miniphone) Pin Signal

1 (Tip) Audio_Out_Left

2 (Ring) Audio_Out_Right

3 (Shield) Ground

External Infrared Transceiver
Connector and Icon

Pin Signal Pin Signal Pin Signal

1 
2 
3

Transmit 
Receive 
Ground

4 
5 
6

5V 
Mode 
Not Used

7 
8 

Not Used 
Not Used

1 2 31 2 3

1 2 3

1 2 3

1 2 3
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Connector Pin Assignments
Monitor
Connector and Icon

Pin Signal Pin Signal Pin Signal

1 
2 
3

Red Analog 
Green Analog 
Blue Analog

6 
7 
8

Ground 
Ground 
Ground

11 
12 
13

Monitor ID 
DDC Serial Data 
Horizontal Sync

4 
5

Not used 
Ground

9 
10

+5V (fused) 
Ground

14 
15

Vertical Sync 
DDC Serial Clock

ATA/ATAPI (IDE) Standard Drive Cable
Connector

Pin Signal Pin Signal Pin Signal

1 
2 
3 
4 
5

Reset 
Ground 
DD7 
DD8 
DD6

15 
16 
17 
18 
19

DD1 
DD14 
DD0 
DD15 
Ground

29 
30 
31 
32 
33

DMAK 
Ground 
INTRQ 
IOCS16 
DA1

6 
7 
8 
9 
10

DD9 
DD5 
DD10 
DD4 
DD11

20 
21 
22 
23 
24

(Key) 
DMARQ 
Ground 
DIOW 
Ground

34 
35 
36 
37 
38

PDIAG (cable detect) 
DA0 
DA2 
CS1FX 
CS3FX

11 
12 
13 
14

DD3 
DD12 
DD2 
DD13

25 
26 
27 
28

DIOR 
Ground 
IORDY 
CSEL

39 
40 
 

DASP 
Ground 
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Connector Pin Assignments
Accelerated Graphics Port (AGP) 
Connector

Pin Signal A Signal B Pin Signal A Signal B

1 
2 
3 
4 
5

+12 V 
TYPEDET# 
Reserved 
USB- 
Ground

OVRCNT# 
+ 5V  
+ 5V  
USB+ 
Ground

34 
35 
36 
37 
38

Vddq  
AD22 
AD20 
Ground 
AD18

Vddq  
AD21 
AD19 
Ground 
AD17

6 
7 
8 
9 
10

INTA# 
RST# 
GNT# 
VCC3.3 
ST1

INTB# 
CLK 
REQ# 
VCC3.3 
ST0

39 
40 
41 
42 
43

AD16 
Vddq 
FRAME# 
Reserved 
Ground

C/BE2# 
Vddq 
IRDY# 
3.3VAux 
Ground

11 
12 
13 
14 
15

Reserved 
PIPE# 
Ground 
WBF# 
SBA1

ST2 
RBF# 
Ground 
Reserved 
SBA0

44 
45 
46 
47 
48

Reserved 
VCC 3.3 
TRDY# 
STOP# 
PME#

Reserved 
VCC 3.3 
DEVSEL# 
Vddq  
PERR#

16 
17 
18 
19 
20

VCC 3.3 
SBA3 
SB_STB# 
Ground 
SBA5

VCC 3.3 
SBA2 
SB_STB 
Ground 
SBA4

49 
50 
51 
52 
53

Ground 
PAR 
AD15 
Vddq 
AD13

Ground 
SERR# 
C/BE1# 
Vddq 
AD14

21 
22 
23 
24 
25

SBA7 
Reserved 
Ground 
Reserved 
VCC 3.3

SBA6 
Reserved 
Ground 
3.3 Vaux 
VCC 3.3

54 
55 
56 
57 
58

AD11 
Ground 
AD9 
C/BE0# 
Vddq 

AD12 
Ground 
AD10 
AD8 
Vddq 

26 
27 
28 
29 
30

AD30 
AD28 
VCC 3.3 
AD26 
AD24

AD31 
AD29
VCC 3.3 
AD27 
AD25

59 
60 
61 
62 
63

AD_STB0# 
AD6 
Ground 
AD4 
AD2

AD_STB0 
AD7 
Ground 
AD5
AD3

31 
32 
33

Ground 
AD_STB1# 
C/BE3#

Ground 
AD_STB1 
AD23

64 
65 
66

Vddq  
AD0 
VREFGC

Vddq 
AD1 
VREFCG
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Connector Pin Assignments
20-Pin Power 
Connector

Pin Signal Pin Signal Pin Signal Pin Signal

1 
2 
3 
4 
5

+3.3 V 
+3.3 V 
GND 
+5 V 
GND

6 
7 
8 
9 
10

+5 V 
GND 
POK 
+5 Vaux 
+12 V

11 
12 
13 
14 
15

+3.3 V 
-12 V 
GND 
PSON 
GND

16 
17 
18 
19 
20

GND 
GND 
-5 V 
+5 V 
+5 V

4-Pin Power (for CPU)
Connector and Icon Pin Signal

1 GND

2 GND

3 +12 V

4 -12 V

20

10

11�
�

1
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B
Power Cord Set Requirements

The voltage select switch feature on the workstation permits it to operate from any line voltage 
between 100-120 or 220-240 volts AC. 

The power cord set received with the workstation meets the requirements for use in the country 
where you purchased the equipment.

Power cord sets for use in other countries must meet the requirements of the country where you 
use the workstation. For more information on power cord set requirements, contact your 
authorized HP dealer, reseller, or service provider.

General Requirements
The requirements listed below are applicable to all countries: 

1. The length of the power cord set must be at least 6.00 feet (1.8 m) and a maximum of 9.75 
feet (3.0 m).

2. All power cord sets must be approved by an acceptable accredited agency responsible for 
evaluation in the country where the power cord set will be used.

3. The power cord set must have a minimum current capacity of 10A and a nominal voltage 
rating of 125 or 250 volts AC, as required by each country’s power system.

4. The appliance coupler must meet the mechanical configuration of an EN 60 320/IEC 320 
Standard Sheet C13 connector, for mating with appliance inlet on the Switch Box.
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Power Cord Set Requirements
Country-Specific Requirements
Additional requirements specific to a country are shown in parentheses and explained below. 

Country
Accrediting

Agency Country
Accrediting

Agency

Australia (1) 
Austria (1) 
Belgium (1)  
Canada (2)

EANSW 
OVE 
CEBC 
CSA

Italy (1) 
Japan (3) 
Norway (1) 
Sweden (1)

IMQ 
METI 
NEMKO 
SEMKO

Denmark (1) 
Finland (1)  
France (1)  
Germany (1) 

DEMKO 
SETI 
UTE 
VDE

Switzerland (1) 
United Kingdom (1) 
United States (2) 

SEV 
BSI 
UL 

1. The flexible cord must be <HAR> Type HO5VV-F, 3-conductor, 1.0 mm2 conductor size. 
Power cord set fittings (appliance coupler and wall plug) must bear the certification mark of 
the agency responsible for evaluation in the country where it will be used.

2. The flexible cord must be Type SJT or equivalent, No. 18 AWG, 3-conductor. The wall plug 
must be a two-pole grounding type with a NEMA 5-15P (15A, 125V) or NEMA 6-15P 
(15A 250V) configuration.

3. Appliance coupler, flexible cord, and wall plug must bear a “T” mark and registration 
number in accordance with the Japanese Dentori Law. Flexible cord must be Type VCT or 
VCTF, 3-conductor, 1.0 mm2 conductor size. Wall plug must be a two-pole grounding type 
with a Japanese Industrial Standard C8303 (7A, 125V) configuration.
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C
POST Error Messages

An error message results if the Power-On Self-Test (POST) encounters a problem. This test runs 
when the system is turned on, checking assemblies within the workstation and reporting any 
errors found. 

Some workstations do not use all of the codes listed.

POST Error Messages 

Screen Message Probable Cause Recommended Action

101-Option ROM Error System ROM checksum. Verify the correct ROM.
Flash the ROM if needed.
If an expansion card was recently 
added, remove it and see if the problem 
remains. 
Clear CMOS.
If the message disappears, there may be 
a problem with the expansion card.
Replace the system board.

102-System Board 
Failure

DMA, timers, etc. Clear CMOS.
Remove expansion boards.
Replace the system board.

103-System Board 
Failure

DMA, timers, etc. Clear CMOS.
Remove expansion boards.
Replace the system board.

150-SafePost Active A PCI expansion card is 
not responding.

Restart the workstation. 
Disable SafePost.
If the expansion card does not respond, 
replace the card. 

162-System Options 
Not Set

Configuration incorrect. 
RTC (real-time clock) 
battery may need to be 
replaced. 

Run Computer Setup (F10 Setup).
Set the date and time under Control 
Panel or in F10 Setup depending on 
the operating system.
If the problem persists, replace the RTC 
battery.
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POST Error Messages
163-Time & Date Not 
Set

Invalid time or date in 
configuration memory. 
RTC (real-time clock) 
battery may need to be 
replaced. 
CMOS jumper may not 
be properly installed.

Set the date and time under Control 
Panel or in F10 Setup depending on 
the operating system. 
If the problem persists, replace the RTC 
battery. 

164-Memory Size Error Memory configuration is 
incorrect.

Run Computer Setup (F10 Setup) or 
Windows utilities.
Make sure memory module(s) (if any) are 
installed properly.
If third party memory has been added, 
test using HP-only memory.
Verify proper memory module type.

183-Invalid Processor 
Jumper Setting

System board jumper 
improperly set.

Reset system board jumpers to match 
processor and bus speeds (select 
models).

201-Memory Error RAM failure. Run Computer Setup (F10 Setup) or 
Windows utilities.
Ensure memory and continuity modules 
are installed correctly.
Verify proper memory module type.
Remove and replace memory module(s) 
one at a time to isolate faulty module.
Replace the faulty memory module(s).
If error persists after replacing memory 
modules, replace the system board.

202-Memory Type 
Mismatch

Memory modules do not 
match each other.

Replace memory modules with matched 
sets.

207-ECC Corrected 
Single Bit Errors in 
Memory Socket(s) y,y

Single Bit ECC error. Verify proper memory module type.
Try another memory socket.
Replace memory module if problem 
persists.

212-Failed Processor Processor has failed to 
initialize.

Reseat the processor in its socket.
If the processor does not respond, 
replace it.

213-Incompatible 
memory Module in 
memory Socket(s)  
X,X, X

A memory module in 
memory socket identified 
in the error message is 
missing critical SPD 
information, or is 
incompatible with the 
chipset.

Verify proper memory module type.
Try another memory socket.
Replace memory with a module 
conforming to the SPD standard.

POST Error Messages 

Screen Message Probable Cause Recommended Action
C–2 Service and Technical Reference Guide, xw3100



POST Error Messages
214-DIMM 
Configuration Warning

Populated DIMM 
Configuration is 
unbalanced.

2 DIMMS - For maximum performance, 
place both DIMMs in the two BLACK 
DIMM slots.
4 DIMMS - For maximum performance, 
swap one DIMM in a BLUE slot with one 
in a BLACK slot.

301-Keyboard Error Keyboard failure. Reconnect keyboard with workstation 
turned off.
Check connector for bent or missing 
pins.
Ensure that none of the keys are 
depressed.
Replace keyboard.

303-Keyboard 
Controller Error

I/O board keyboard 
controller.

Reconnect keyboard with workstation 
turned off.
Replace the system board.

304-Keyboard or 
System Unit Error

Keyboard failure. Reconnect the keyboard with workstation 
turned off.
Ensure that none of the keys are 
depressed.
Replace keyboard.
Replace system board. 

401-Parallel Port 1 
Address Assignment 
Conflict

IRQ address conflicts with 
another device.

Reset the IRQ.

402-Parallel Port 2 
Address Assignment 
Conflict

IRQ address conflicts with 
another device.

Reset the IRQ.

403-Parallel Port 3 
Address Assignment 
Conflict

IRQ address conflicts with 
another device.

Reset the IRQ.

404-Parallel Port 
Address Conflict 
Detected

Both external and internal 
ports are assigned to 
parallel port X.

Remove any parallel expansion cards.
Clear CMOS.
Reconfigure card resources and/or run 
Computer Setup (F10 Setup). 

410-Audio Interrupt 
Conflict

IRQ address conflicts with 
another device.

Reset the IRQ.

411-Network Interface 
Card Interrupt Conflict

IRQ address conflicts with 
another device.

Reset the IRQ.

417-Network Interface 
card Failure

Failure to read MAC 
address information from 
NIC.

Unplug AC power cord, wait 5 seconds, 
then reboot unit.

POST Error Messages 

Screen Message Probable Cause Recommended Action
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POST Error Messages
501-Display Adapter 
Failure

Graphics display 
controller.

Reseat the graphics card (if applicable).
Clear CMOS.
Verify that the monitor is attached and 
turned on.
Replace the graphics controller.

510-Splash Screen 
image corrupted

Splash Screen image has 
errors.

Install latest version of ROMPaq to 
restore image.

511-CPU, CPUA, or 
CPUB Fan not detected

Fan is not connected or 
may have malfunctioned.

Reseat fan cable.
Reseat the fan.
Replace the fan.

512-Chassis, rear 
chassis, or front chassis 
fan not detected

Fan is not connected, 
may have malfunctioned.

Reseat chassis, rear chassis, or front 
chassis fan cable.
Reseat chassis, rear chassis, or front 
chassis fan.
Replace chassis, rear chassis, or front 
chassis fan.

514-CPU or Chassis 
Fan not detected.

CPU fan is not connected 
or may have 
malfunctioned.

Reseat CPU or chassis fan.
Replace CPU or chassis fan.

520-Single Monitor 
Configuration warning

Single monitor 
configuration with 
monitor attached to video 
port 2.

Turn off unit, attach monitor to video port 
1, then restart unit.

601-Diskette Controller 
Error

Diskette controller 
circuitry or floppy drive 
circuitry incorrect.

Run Computer Setup (F10 Setup).
Check and/or replace cables.
Clear CMOS.
Replace diskette drive. 
Replace the system board.

602-Diskette Boot 
Record Error

Diskette in drive A not 
bootable.

Replace the diskette.

605-Diskette Drive Type 
Error

Mismatch in drive type. Run Computer Setup (F10 Setup).
Disconnect any other diskette controller 
devices (tape drives).
Clear CMOS.

610-External Storage 
Device Failure

External tape drive not 
connected.

Reinstall tape drive or press F1 and 
allow system to reconfigure without the 
drive.

611-Primary Floppy Port 
Address Assignment 
Conflict

Configuration error. Run Computer Setup (F10 Setup). 
Remove expansion cards.
Clear CMOS.

POST Error Messages 

Screen Message Probable Cause Recommended Action
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POST Error Messages
660-Display Cache is 
Detected Unreliable

Integrated video 
controller display cache 
not working properly and 
will be disabled.

Replace system board if minimal video 
degrading is an issue.

912-Computer Cover 
Has Been Removed 
Since Last System Start 
Up

No action required.

914-Hood Lock Coil is 
not Connected

Smart cover lock 
mechanism is missing or 
not connected.

Reconnect or replace hood locking 
mechanism.
Reseat or replace hood locking 
mechanism cable.

916-Power Button not 
Connected

Power button cable not 
connected.

Connect power button cable.

917-Front Audio not 
Connected

Front audio cable not 
connected.

Connect the front audio cable.

919-Front Panel, 
MultiPort, and/or 
MultiBay Risers not 
Detected.

Riser card has been 
removed or has not been 
reinstalled properly in the 
system.

Unplug workstation and install/reinstall 
riser cord.

1151-Serial Port 1 
Address Conflict 
Detected

Both external and internal 
serial ports are assigned 
to COM1.

Remove any Comm port expansion 
cards.
Clear CMOS.
Reconfigure card resources and/or run 
Computer Setup (F10 Setup). Run 
Computer Setup or Windows utilities.

1152-Serial Port 2 
Address Conflict 
Detected

Both external and internal 
serial ports are assigned 
to COM2.

Remove any Comm port expansion 
cards.
Clear CMOS.
Reconfigure card resources and/or run 
Computer Setup (F10 Setup). Run 
Computer Setup or Windows utilities.

1155-Serial Port 
Address Conflict 
Detected

Both external and internal 
serial ports are assigned 
to same IRQ.

Remove any Comm port expansion 
cards.
Clear CMOS.
Reconfigure card resources and/or run 
Computer Setup (F10 Setup).Run 
Computer Setup or Windows utilities.

1156-Serial Port A 
Cable Not Detected

Serial Port cable 
assembly disconnected 
from system board.

Turn off unit, disconnect the power cable 
from the power source, open the 
workstation chassis and attach serial 
port cable to the system board.

POST Error Messages 

Screen Message Probable Cause Recommended Action
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POST Error Messages
1157-Front Cables Not 
Detected

Front cable assembly 
(audio and USB) 
disconnected from the 
system board.

Turn off unit, disconnect the power cable 
from the power source, open the 
workstation chassis and attach front 
cable assembly to the system board.

1201-System Audio 
Address Conflict 
Detected

Device IRQ address 
conflicts with another 
device.

Reset the IRQ.

1202-MIDI Port Address 
Conflict Detected

Device IRQ address 
conflicts with another 
device.

Reset the IRQ.

1203-Game Port 
Address Conflict 
Detected

Device IRQ address 
conflicts with another 
device.

Reset the IRQ

1720 SMART Hard 
Drive Detect Imminent 
Failure

Hard drive is about to 
fail. (Some hard drives 
have a firmware patch 
that will fix an erroneous 
error message.)

Determine if hard drive is giving correct 
error message. Run the Drive Protection 
System text if applicable.
Apply firmware patch if applicable. (see 
www.hp.com/support)
Back up contents and replace hard drive.

1794-Inaccessible 
devices attached to 
primary IDE controller

Devices attached to the 
primary IDE (Parallel ATA) 
controller are 
inaccessible while “SATA 
Configuration” is set to 
“Replace Primary IDE 
Controller” in Computer 
Setup.

If you do not require access to SATA 
devices, or if you are using Windows 
2000 or Windows XP, enter the devices 
attached to the primary IDE (Parallel 
ATA) channel.

1800-Temperature Alert Internal temperature 
exceeds specification.

Check that workstation air vents are not 
blocked and cooling fan is running.
Verify processor speed selection.
Replace the processor.
Replace the system board.

1801-Microcode Patch 
Error

Processor not supported 
by ROM BIOS.

Upgrade BIOS to proper version.

1998-Master Boot 
Record has been lost.

The previously saved 
copy of the MBR has 
been corrupted.

Run Computer Setup and save the MBR 
of the current bootable disk.

POST Error Messages 

Screen Message Probable Cause Recommended Action
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POST Error Messages
1998-Master Boot 
Record has been 
changed.

The current MBR does not 
match the previously 
saved copy of the MBR.

Use extreme caution, The MBR may have 
been updated due to normal disk 
maintenance activities (disk manager, 
fdisk, or format). Replacing the 
previously saved MBR in such situations 
can cause data loss. If certain that the 
MBR change is unintentional and 
undesired (e.g. due to a virus), run 
Computer Setup and restore the 
previously saved MBR copy. Otherwise, 
run Computer Setup and either disable 
MBR security or save the MBR of the 
current bootable disk.

2000-Master Boot 
Record Hard Drive has 
Changed.

The current bootable hard 
drive is not the same as 
the one that was present 
when MBR security was 
enabled.

Run Computer Setup and either disable 
MBR security or save the MBR of the 
current bootable disk.

Invalid Electronic Serial 
Number.

Electronic serial number 
has become corrupted.

Run Computer Setup. If Setup already 
has data in the field or will not allow the 
serial number to be entered, download 
from http://www.hp.com and run 
SP5572.EXE (SNZERO.EXE).
Run Computer Setup and try to enter 
serial number under Security, System ID, 
then save changes.

ECC Multiple Bit Error 
Detected in Memory 
Module.

Chipset has detected 
more than one bad bit in 
a 64-bit quadword of the 
memory array.

Replace the memory module.

Parity Check 2. Parity RAM failure. Run Computer Setup and Diagnostic 
utilities.

POST Error Messages 

Screen Message Probable Cause Recommended Action
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Troubleshooting Without Diagnostics

E-Support
For online access to technical support information and tools, go to www.hp.com/support. 
Support resources include web-based troubleshooting tools, technical knowledge databases, 
driver and path downloads, online communities, and proactive notification services.

Troubleshooting Checklist
This section describes some simple, preliminary tests and guidelines for troubleshooting the 
workstation without using the diagnostics.

■ Are the workstation and monitor connected to a working electrical outlet?

■ Is the voltage select switch is set to the appropriate voltage for your region (115V or 230V)?

■ Is the workstation turned on?

■ Is the green power light illuminated?

■ Is the monitor turned on?

■ Is the green monitor light illuminated?

■ Turn up the monitor brightness and contrast controls if the monitor is dim.

■ If the system has multiple video sources (embedded, PCI, or AGP adapters) installed 
(embedded video on select models only) and a single monitor, the monitor must be plugged 
into the monitor connector on the source selected as the primary VGA adapter. During boot, 
the other monitor connectors are disabled and if the monitor is connected into these ports, the 
monitor will not function. You can select which source will be the default VGA source in 
Computer (F10) Setup.

■ Press and hold any key. If the system beeps, then the keyboard is operating correctly.

■ Check all cables for loose or incorrect connections.

■ Reconfigure the workstation after installing a non–Plug and Play expansion board or other 
option, such as a diskette drive.

■ Are all of the necessary device drivers installed?

■ Have all printer drivers been installed for each application?

■ Remove all diskettes from the diskette drives before you turn on the system.

■ Are all switches set correctly?

■ Is the NIC Remote Wakeup cable (featured on some models) connected between the NIC and 
the riser/system board?
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Solving Minor Problems

Solving Minor Problems 

Problem Cause Possible Solution

Workstation appears 
locked up and will not 
turn off when the power 
button is pressed.

Software control of the 
power switch is not 
functional.

1. Press and hold the power button 
for at least four seconds until the 
workstation turns off.

2. Disconnect electrical plug from 
outlet.

Workstation will not 
respond to USB 
keyboard or mouse.

Workstation is in 
standby mode.

Press the power button to resume from 
standby mode.

Ä CAUTION: When attempting to resume from standby mode, do not hold down the power 
button for more than four seconds. Otherwise, the workstation will shut down and you will lose 
your data.

Workstation date and 
time display is incorrect.

RTC (real-time clock) 
battery may need to be 
replaced. 

1. Reset the date and time under 
Control Panel. 

2. Replace the RTC battery.

Workstation appears to 
pause periodically.

Network driver is loaded 
and no network 
connection is established.

Establish a network connection, or 
use Computer Setup or Microsoft 
Windows Device Manager to disable 
the network controller.

Cursor will not move 
using the arrow keys on 
the keypad.

The Num Lock key 
may be on.

Press the Num Lock key. The Num 
Lock key can be disabled (or 
enabled) in Computer Setup.

Cannot remove 
workstation cover or 
access panel.

Smart Cover Lock, 
featured on some 
workstations, is locked.

1. Unlock the Smart Cover Lock 
using Computer Setup.

2. Use the Smart Cover FailSafe Key 
in case of forgotten password, 
power loss, or workstation 
malfunction.

Poor performance is 
experienced.

Processor is hot. 1. Ensure airflow to the workstation 
is not blocked.

2. Ensure the fans are connected 
and working properly (some fans 
only operate when needed).

3. Ensure the processor heatsink is 
installed properly.

Hard drive is full. Transfer data from the hard drive to 
create more space on the hard drive.
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Workstation powered 
off automatically and 
the Power LED flashes 
Red two times, once 
every second, followed 
by a two second pause.

Processor thermal 
protection activated:
A fan may be blocked or 
not turning.
OR 
The heatsink is not 
properly attached to the 
processor.

1. Ensure workstation air vents are 
not blocked and the cooling fan 
is running.

2. Open hood, press power button, 
and see if the processor fan 
spins. If not spinning, make sure 
the fan's cable is plugged onto 
the system board header. Ensure 
the fan is fully/properly seated or 
installed.

3. Replace the processor fan.
4. Reseat processor heatsink and 

verify that the fan assembly is 
properly attached.

System does not power 
on and the LEDs on the 
front of the workstation 
are not flashing.

System unable to power 
on.

Press and hold the power button for 
less than 4 seconds. If the hard drive 
LED turns green, then:
1. Check that the voltage selector is 

set to the appropriate voltage. 
2. Remove the expansion cards one 

at a time until the 3.3 V_aux light 
on the system board turns on.

3. Replace the system board.
OR
Press and hold the power button for 
less than 4 seconds. If the hard drive 
LED does not turn on green then:
1. Check that the unit is plugged 

into a working AC outlet.
2. Open hood and check that the 

power button harness is properly 
connected to the system board.

3. Check that both power supply 
cables are properly connected to 
the system board.

4. If the 3.3 V_aux light on the 
system board is on, then replace 
the power button harness.

5. If the 3.3 V_aux light on the 
system board is off, then replace 
the power supply.

6. Replace the system board.

Solving Minor Problems (Continued)

Problem Cause Possible Solution
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Solving Power Supply Problems

Solving Power Supply Problems 

Problem Cause Solution

Power supply shuts down 
intermittently.

Voltage selector switch 
on rear of workstation 
chassis not switched to 
correct line voltage.

Select the proper AC voltage.

Power supply fault. Replace the power supply.

Workstation powered off 
automatically and the 
Power LED flashes Red two 
times, once every second, 
followed by a two second 
pause.

Processor thermal 
protection activated:
A fan may be blocked 
or not turning.
OR 
The heatsink/fan 
assembly is not properly 
attached to the 
processor.

1. Ensure that the workstation air 
vents are not blocked and the 
cooling fan is running.

2. Open hood, press the power 
button, and see if the processor 
fan spins. If the processor fan is 
not spinning, make sure the 
fan's cable is plugged onto the 
system board header. Ensure 
the fan is fully/properly seated 
or installed.

3. Replace the processor fan.
4. Reseat processor heatsink and 

verify that the fan assembly is 
properly attached.

Power LED flashes Red, 
once every two seconds.

Power failure (power 
supply is overloaded).

1. Check that the voltage selector, 
is set to the appropriate voltage. 

2. Open the hood and ensure the 
4-wire power supply cable is 
seated into the connector on the 
system board.

3. Check if a device is causing the 
problem by removing ALL 
attached devices). Power on the 
system. If the system enters the 
POST, then power off and 
replace one device at a time 
and repeat this procedure until 
failure occurs. Replace the 
device causing the failure. 
Continue adding devices one at 
a time to ensure all devices are 
functioning properly.

4. Replace the power supply.
5. Replace the system board.
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Solving Diskette Problems

Solving Diskette Problems 

Problem Cause Solution

Diskette drive light stays on. Diskette is damaged. In Microsoft Windows 2000 and 
Microsoft Windows XP, right-click 
Start, click Explore, and select a 
drive. Select File > Properties > 
Tools. Under Error-checking, 
click Check Now.

Diskette is incorrectly 
inserted.

Remove diskette and reinsert.

Drive button is not 
pushed in.

Push in drive button.

Files on diskette are 
damaged.

Check the program diskettes.

Drive cable is not 
properly connected.

Reconnect power cable. Ensure that 
all four pins are connected.

Drive not found. Cable is loose. Reseat diskette drive data and 
power cables.

Removable drive is not 
seated properly.

Reseat the drive.

Diskette drive cannot write 
to a diskette.

Diskette is not 
formatted.

Format the diskette.

Diskette is 
write-protected.

Use another diskette or remove the 
write protection.

Writing to the wrong 
drive.

Check the drive letter in the path 
statement.

Not enough space is 
left on the diskette.

Use another diskette.

Diskette write control is 
enabled.

Use Computer Setup to check the 
storage security feature disabled 
settings.

Diskette is damaged. Replace the damaged disk.

Cannot format diskette. Invalid media reported. When formatting a disk in MS-DOS, 
you may need to specify diskette 
capacity. For example, to format a 
1.44-MB diskette, type the following 
command at the MS-DOS prompt:

FORMAT A: /F:1440

A problem has occurred 
with a disk transaction.

The directory structure is 
bad, or there is a 
problem with a file.

In Windows 2000 and Windows 
XP, right-click Start, click Explore, 
and select a drive. Select File > 
Properties > Tools. Under 
Error-checking, click Check 
Now.
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Solving Hard Drive Problems

Diskette drive cannot read 
a diskette.

Diskette is not 
formatted.

Format the diskette.

You are using the wrong 
diskette type for the 
drive type.

Check the type of drive that you 
are using and use the correct 
diskette type.

You are reading the 
wrong drive.

Check the drive letter in the path 
statement.

Diskette is damaged. Replace the diskette with a new one.

“Invalid system disk” 
message is displayed.

A diskette that does not 
contain the system files 
needed to start the 
workstation has been 
inserted in the drive.

When drive activity stops, remove 
the diskette and press the 
Spacebar. The workstation should 
start up.

Diskette error has 
occurred.

Restart the workstation by pressing 
the power button.

Cannot Boot to Diskette. Diskette is not bootable. Replace with a bootable diskette.

Diskette boot has been 
disabled in Computer 
Setup.

Run Computer Setup and enable 
diskette boot in Storage > Boot 
Order.

Removable media boot 
has been disabled in 
Computer Setup.

Run Computer Setup and enable 
Removable Media Boot in 
Storage > Storage Options.

Diskette MBR validation 
is enabled.

Run Computer Setup and disable 
Diskette MBR Validation in 
Storage > Storage Options.

Solving Diskette Problems (Continued)

Problem Cause Solution

Solving Hard Drive Problems 

Problem Cause Solution

Hard drive error occurs. Hard disk has bad 
sectors or has failed.

Use a utility to locate and block 
usage of bad sectors. If necessary, 
reformat the hard disk.

Disk transaction problem. Either the directory 
structure is bad or there 
is a problem with a file.

In Windows 2000 and Windows 
XP, right-click Start, click Explore, 
and select a drive. Select File > 
Properties > Tools. Under 
Error-checking, click Check 
Now.

Drive not found (identified). Loose cable. Check cable connections.
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The system may not 
have automatically 
recognized a newly 
installed device.

1. Run Computer Setup.
2. If the system still does not 

recognize the new device, 
check to see if the device is 
listed within Computer Setup. If 
it is listed, the probable cause is 
a driver problem. If it is not 
listed, the probable cause is a 
hardware problem.

3. If this is a newly installed drive, 
enter Setup and try adding a 
POST delay under Advanced 
> Power-On.

Drive jumper settings 
may be incorrect.

If the drive is a secondary drive that 
has just been installed on the same 
cable as the primary drive, verify 
that the jumpers for both drives are 
set correctly.

Drive’s IDE (ATA) 
controller is disabled in 
Computer Setup.

Run Computer Setup and enable the 
Primary and Secondary IDE (ATA) 
controllers in Storage > Storage 
Options.

Drive responds slowly 
immediately after 
power-up.

Run Computer Setup and increase 
the POST Delay in Advanced > 
Power-On Options.

Nonsystem disk/NTLDR 
missing message.

System is trying to start 
from a non bootable 
diskette.

Remove the diskette from the diskette 
drive.

Nonsystem disk/NTLDR 
missing message. 
(continued)

System is trying to start 
from a damaged hard 
drive.

1. Insert a bootable diskette into 
the diskette drive and restart the 
workstation.

2. If the hard drive is still 
inaccessible and MBR Security 
is enabled, try restoring the 
previously saved MBR image by 
entering Setup and selecting 
Security > Restore Master 
Boot Record.

System files missing or 
not properly installed.

1. Insert a bootable system diskette 
and restart.

2. Verify hard drive is partitioned 
and formatted. 

3. Install system files for the 
appropriate operating system if 
necessary.

Solving Hard Drive Problems (Continued)

Problem Cause Solution
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Hard drive boot 
disabled in Computer 
Setup.

Run Computer Setup and enable the 
hard drive entry in the Storage > 
Boot Order list.

Second Ultra ATA hard 
drive does not perform 
optimally.

Using the wrong cable 
for the drive type.

Reinstall the second Ultra ATA hard 
drive using an 80-conductor cable 
(standard on select models.)

Both slow and fast 
UATA devices are on 
the same data cable.

Connect slower UATA devices to a 
separate data cable connected to 
the secondary IDE (ATA) controller.

Workstation will not start. Hard drive is damaged. Observe the beeps and LED lights 
on the front of the workstation. See 
Appendix C “POST Error 
Messages”.

Workstation seems to be 
locked up.

Program in use has 
stopped responding to 
commands.

1. Attempt the normal Windows 
“Shut Down” procedure. 

2. Press the power button for 
four or more seconds to turn off 
the power. 

3. Restart the workstation using the 
power button.

Solving Hard Drive Problems (Continued)

Problem Cause Solution
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Solving Display Problems

Solving Display Problems 

Problem Cause Solution

Blank screen (no video). The cable connections 
are not correct.

Check the cable connections from 
the monitor to the workstation and to 
the electrical outlet.

Screen blanking utility 
installed or energy 
saver features enabled.

Press any key or click the mouse 
button and, if set, type your 
password.

System ROM is bad; 
system is running in 
FailSafe Boot Block 
mode (indicated by 
eight beeps).

Reflash the ROM using a ROMPaq 
diskette.

Fixed-sync monitor will 
not sync at the 
resolution chosen.

Ensure that the monitor can accept 
the same horizontal scan rate as the 
resolution chosen.

Workstation is in 
standby mode.

Press the power button to resume 
from standby mode.

Ä CAUTION: When attempting to resume from standby mode, do not hold down the 
power button for more than four seconds. Otherwise, the workstation will shut down 
and you will lose your data.

Monitor cable plugged 
into the wrong 
connector.

If the workstation system has both 
an integrated graphics connector 
and an AGP card connector, plug 
the monitor cable into the AGP card 
connector.

Monitor settings in the 
workstation are not 
compatible with the 
monitor.

1. Restart the workstation and 
press F8 during startup when 
you see “Press F8” in the bottom 
right corner of the screen.

2. Using the keyboard arrow keys, 
select Enable VGA Mode 
and press Enter.

3. In Windows Control Panel, 
double-click the Display icon 
and select the Settings tab.

4. Use the sliding control to reset 
the resolution.
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Power LED flashes Red six 
times, once every second, 
followed by a two second 
pause, and the workstation 
beeps six times.

Pre-video graphics 
error.

For systems with a graphics card:
1. Reseat the graphics card. 
2. Replace the graphics card.
3. Replace the system board.

For systems with integrated 
graphics, replace the system board.

Monitor does not function 
properly when used with 
energy saver features.

Monitor without energy 
saver capabilities is 
being used with energy 
saver features enabled.

Disable monitor energy saver 
feature.

Dim characters. The brightness and 
contrast controls are not 
set properly.

Adjust the monitor brightness and 
contrast controls.

Cables are not properly 
connected.

Check that the graphics cable is 
securely connected to the graphics 
card and the monitor.

Blurry video or requested 
resolution cannot be set.

If the graphics controller 
was upgraded, the 
correct video drivers 
may not be loaded.

Install the video drivers included in 
the upgrade kit.

Monitor is not capable 
of displaying requested 
resolution.

Change requested resolution.

The picture is broken up, 
rolls, jitters, or flashes.

The monitor connections 
may be incomplete or 
the monitor may be 
incorrectly adjusted.

1. Be sure the monitor cable is 
securely connected to the 
workstation.

2. In a two-monitor system or if 
another monitor is in close 
proximity, be sure the monitors 
are not interfering with each 
other’s electromagnetic field by 
moving them apart.

3. Fluorescent lights or fans may 
be too close to the monitor.

Monitor needs to be 
degaussed.

Degauss the monitor. 

Vibrating or rattling noise 
coming from inside a CRT 
monitor when powered on.

Monitor degaussing coil 
has been activated.

None. It is normal for the 
degaussing coil to be activated 
when the monitor is powered on.

Clicking noise coming from 
inside a CRT monitor.

Electronic relays have 
been activated inside 
the monitor.

None. It is normal for some monitors 
to make a clicking noise when 
turned on and off, when going in 
and out of standby mode, and when 
changing resolutions.

Solving Display Problems (Continued)

Problem Cause Solution
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High pitched noise coming 
from inside a flat panel 
monitor.

Brightness and/or 
contrast settings are too 
high.

Lower brightness and/or contrast 
settings.

Fuzzy focus; streaking, 
ghosting, or shadowing 
effects; horizontal scrolling 
lines; faint vertical bars; or 
unable to center the picture 
on the screen. 
(flat panel monitors using 
an analog VGA input 
connection only)

Flat panel monitor’s 
internal digital 
conversion circuits may 
be unable to correctly 
interpret the output 
synchronization of the 
graphics card.

1. Select the monitor’s 
Auto-Adjustment option in the 
monitor’s on-screen display 
menu.

2. Manually synchronize the Clock 
and Clock Phase on-screen 
display functions. Download 
SoftPaq SP20930 or SP22333, 
depending on the monitor, to 
assist with the synchronization.

Certain typed symbols do 
not appear correct.

The font you are using 
does not support that 
particular symbol.

Use the Character Map to locate the 
and select the appropriate symbol. 
Click Start > All Programs > 
Accessories > System Tools > 
Character Map. You can copy 
the symbol from the Character Map 
into a document.

Solving Display Problems (Continued)

Problem Cause Solution
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Solving Audio Problems

Solving Audio Problems 

Problem Cause Solution

Sound does not come 
out of the speaker or 
headphones.

Software volume control 
is turned down.

Double-click the Speaker icon on 
the taskbar and use the volume 
slider to adjust the volume.

The external speakers 
are not turned on.

Turn on the external speakers.

External speakers 
plugged into the wrong 
audio jack.

See the sound card documentation 
for proper speaker connection.

Audio cable not 
connected.

Connect audio cable between CD 
or DVD-ROM drive and the system 
board.

Digital CD audio is not 
enabled.

Enable digital CD audio:
1. From the Control Panel, select 

System.
2. On the Hardware tab, click 

the Device Manager button.
3. Right-click on the CD/DVD 

device and select Properties.
4. On the Properties tab, make 

sure “Enable digital CD 
audio for this CD-ROM 
device” is checked.

Headphones or devices 
connected to the 
line-out connector mute 
the internal speaker.

Turn on and use headphones or 
external speakers, if connected, or 
disconnect headphones or external 
speakers.

Volume is muted. 1. From the Control Panel 
program, click Sound, 
Speech and Audio 
Devices, then click Sounds 
and Audio Devices.

2. Click the Mute check box to 
remove the check mark from 
the box.

Workstation is in 
standby mode.

Press the power button to resume 
from standby mode.

Ä CAUTION: When attempting to resume from standby mode, do not hold down the 
power button for more than four seconds. Otherwise, the workstation will shut down 
and you will lose your data.
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Noise or no sound comes 
out of the speakers or 
headphones.

1. If using digital speakers that 
have a stereo jack and want the 
system to auto-switch to digital, 
use a stereo-to-mono adapter 
to properly engage the 
auto-sense feature or use the 
multimedia device properties 
to manually switch the audio 
signal from analog to digital.

2. If the headphones have a mono 
jack, use the multimedia device 
properties to switch the system 
to analog out.

✎ If you set digital as the Output Mode, the internal speaker and external analog 
speakers will no longer output audio until you switch back to an auto-sense or  
analog mode. 
 
If you set analog as the Output Mode, external digital speakers will not function 
until you change the output mode back to an auto-sense or digital mode. 

Sound cuts in and out. Processor resources are 
being used by other 
open applications.

Shut down all open 
processor-intensive applications.

Workstation appears to be 
locked up while recording 
audio.

The hard disk may be 
full.

1. Before recording, make sure 
there is enough free space on 
the hard disk. 

2. Try recording the audio file in a 
compressed format.

Solving Audio Problems (Continued)

Problem Cause Solution
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Solving Printer Problems

Solving Printer Problems 

Problem Cause Solution

Printer will not print. Printer is not turned on 
and online.

Turn the printer on and make sure it 
is online.

The correct printer 
driver for the 
application are not 
installed.

1. Install the correct printer driver 
for the application.

2. Try printing using the 
MS-DOS command:
DIR C:\ > [printer port]
where [printer port] is the 
address of the printer being 
used. If the printer works, reload 
the printer driver.

If you are on a network, 
you may not have made 
the connection to the 
printer.

Make the proper network 
connections to the printer.

Printer may have failed. Run printer self-test.

Printer will not turn on. The cables may not be 
connected properly.

Reconnect all cables.

Printer prints garbled 
information.

The correct printer 
driver is not installed.

Install the correct printer driver for 
the application.

The cables may not be 
connected properly.

Reconnect all cables.

Printer memory may be 
overloaded.

Reset the printer by turning it off for 
one minute, then turn it back on.

Printer is offline. The printer may be out 
of paper.

1. Check the paper tray and refill it 
if it is empty. 

2. Select online.
D–14 Service and Technical Reference Guide, xw3100



Troubleshooting Without Diagnostics
Solving Keyboard and Mouse Problems

Solving Keyboard Problems

Problem Cause Solution

Keyboard commands and 
typing are not recognized 
by the workstation.

Keyboard connector 
is not properly 
connected.

1. Turn off the workstation. 
2. Reconnect the keyboard to the 

back of the workstation and 
restart the workstation.

If the keyboard is 
connected to your 
workstation through a 
Keyboard, Video, and 
Mouse (KVM) switch, 
the mouse software 
applications might be 
interfering with the 
functionality of the 
keyboard. 

You might need to uninstall the 
mouse software or connect the 
keyboard directly to the keyboard 
and connector on the workstation.

Program in use has 
stopped responding 
to commands.

Shut down the workstation using 
the mouse and then restart the 
workstation.

Keyboard needs 
repairs.

Replace the keyboard.

Workstation is in 
standby mode.

Press the power button to resume 
from standby mode.

Ä CAUTION: When attempting to resume from standby mode, do not hold down the 
power button for more than four seconds. Otherwise, the workstation will shut down 
and you will lose your data.

Cursor will not move using 
the arrow keys on the 
keypad.

The Num Lock key 
may be on.

Press the Num Lock key. The 
Num Lock light should not be on if 
you want to use the arrow keys. The 
Num Lock key can be disabled  
(or enabled) in Computer Setup.

Mouse does not respond to 
movement or is too slow.

Mouse connector is 
not properly plugged 
into the back of the 
workstation.

1. Shut down the workstation using 
the keyboard.

2. Plug the mouse connector into 
the back of the workstation (or 
the keyboard) and restart the 
workstation.
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Solving Hardware Installation Problems
You may need to reconfigure the workstation when you add or remove hardware, such as an 
additional diskette drive. If you install a plug and play device, Windows 2000 and Windows XP 
automatically recognize the device and configure the workstation. If you install a non–plug and 
play device, you must reconfigure the workstation after completing installation of the new 
hardware. In Windows 2000, select the Add New Hardware icon in the Control Panel (for 
Windows XP, use the Add Hardware Wizard) and follow the instructions that appear on the 
screen.

If the mouse is 
connected to your 
workstation through a 
Keyboard, Video, and 
Mouse (KVM) switch, 
the mouse software 
applications might be 
interfering with the 
functionality of the 
mouse. 

You might need to uninstall the 
mouse software or connect the 
mouse directly to the mouse 
connectors on the workstation.

Program in use has 
stopped responding 
to commands.

Shut down the workstation using the 
keyboard and then restart the 
workstation.

Mouse needs repairs. Replace the mouse.

Workstation is in 
standby mode.

Press the power button to resume 
from standby mode.

Ä CAUTION: When attempting to resume from standby mode, do not hold down the 
power button for more than four seconds. Otherwise, the workstation will shut down 
and you will lose your data.

Mouse will only move 
vertically or horizontally, or 
movement is jerky.

Mouse roller ball is 
dirty.

Remove roller ball cover from the 
bottom of the mouse and clean it.

Solving Keyboard Problems

Problem Cause Solution

Solving Hardware Installation Problems 

Problem Cause Solution

A new device is not 
recognized as part of 
the system.

Device is not seated or 
connected properly. 

Ensure that the device is properly 
and securely connected and that 
pins in the connector are not 
bent down.

Cable(s) of new 
external device are 
loose or power cables 
are unplugged.

Ensure that all cables are properly 
and securely connected and that 
pins in the cable or connector are 
not bent down.
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Power switch of new 
external device is not 
turned on.

Turn off the workstation, turn on the 
external device, then turn on the 
workstation to integrate the device 
with the workstation system.

When the system 
advised you of changes 
to the configuration, you 
did not accept them.

Reboot the workstation and follow 
the instructions for accepting the 
changes.

A plug and play board 
may not automatically 
configure when 
added if the default 
configuration conflicts 
with other devices.

Use Windows 2000 or Windows XP 
Device Manager to deselect the 
automatic settings for the board and 
choose a basic configuration that 
does not cause a resource conflict. 
You can also use Computer Setup to 
reconfigure or disable devices to 
resolve the resource conflict.

Workstation will not start. Wrong memory 
modules were used in 
the upgrade or memory 
modules were installed 
in the wrong location.

1. Review the documentation that 
came with the system to 
determine if you are using the 
correct memory modules and to 
verify the proper installation.

2. Observe the beeps and LED 
lights on the front of the 
workstation. See Appendix C 
“POST Error Messages” to 
determine possible causes.

Power LED flashes Red five 
times, once every second, 
followed by a two second 
pause, and the workstation 
beeps five times.

Memory is installed 
incorrectly or is bad.

1. Reseat DIMMs. 
2. Replace DIMMs one at a time to 

isolate the faulty module.
3. Replace third-party memory 

with HP memory.
4. Replace the system board.

Power LED flashes Red six 
times, once every second, 
followed by a two second 
pause, and the workstation 
beeps six times.

Video card is not seated 
properly or is bad, or 
system board is bad.

For systems with a graphics card:
1. Reseat the graphics card. Power 

on the system.
2. Replace the graphics card.
3. Replace the system board.

For systems with integrated 
graphics, replace the system board.

Solving Hardware Installation Problems (Continued)

Problem Cause Solution
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Troubleshooting Without Diagnostics
Solving Network Problems
These guidelines do not discuss the process of debugging the network cabling.

Solving Network Problems 

Problem Cause Solution

Wake-on-LAN feature is 
not functioning.

Wake-on-LAN is not 
enabled.

Use the Network control application 
to enable Wake-on-LAN. 

Network driver does 
not detect network 
controller.

Network controller is 
disabled.

Run Computer Setup and enable 
network controller.

Incorrect network driver. Check the network controller 
documentation for the correct driver 
or obtain the latest driver from the 
manufacturer’s Web site.

Network status link light 
does not turn on or it 
never flashes.

✎ The network status 
light should flash 
when there is 
network activity.

No active network is 
detected.

Check cabling and network 
equipment for proper connection.

Network controller is not 
set up properly.

Use the Network control application 
to verify that the device is working 
properly. 

Network driver is not 
properly loaded.

Reinstall network drivers. 

System cannot autosense 
the network.

Disable auto-sensing capabilities 
and force the system into the correct 
operating mode. 

Diagnostics reports a 
failure.

The cable is not securely 
connected.

Ensure that both ends of the data 
cable are securely connected. 

The cable is attached to 
the incorrect connector.

Ensure that the cable is attached to 
the correct connector.

There is a problem with 
the cable or a device at 
the other end of the cable.

Ensure that the cable and device at 
the other end are operating 
correctly.

Network controller 
interrupt is shared with 
an expansion board.

Under the Computer Setup 
Advanced menu, change the 
resource settings for the board.

The network controller 
is defective.

Replace the NIC.

Diagnostics passes, but 
the workstation does not 
communicate with the 
network.

Network drivers are 
not loaded, or driver 
parameters do not match 
current configuration.

1. Make sure the network drivers 
are loaded and that the driver 
parameters match the 
configuration of the network 
controller.

2. Make sure the correct network 
client and protocol is installed.
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Diagnostics passes, but 
the workstation does not 
communicate with the 
network. (continued)

The network controller 
is not configured for this 
workstation.

Select the Network icon in the 
Control Panel and configure the 
network controller.

Network controller 
stopped working when 
an expansion board was 
added to the workstation.

Network controller 
interrupt is shared with an 
expansion board.

Under the Computer Setup 
Advanced menu, change the 
resource settings for the board.

The network controller 
requires drivers.

Verify that the drivers were not 
accidentally deleted when the 
drivers for a new expansion board 
were installed.

The expansion board 
installed is a network card 
(NIC) and conflicts with 
the embedded NIC.

Under the Computer Setup 
Advanced menu, change the 
resource settings for the board.

Network controller stops 
working without apparent 
cause.

The files containing the 
network drivers are 
corrupted.

Reinstall the network drivers, using 
the Restore Plus! CD.

The cable is not securely 
connected.

Ensure that both ends of the cable 
are securely attached to the correct 
devices.

The network controller is 
defective.

Replace the NIC.

New network card will 
not boot.

New network card may be 
defective or may not meet 
industry-standard 
specifications.

Install a working, industry-standard 
NIC, or change the boot sequence 
to boot from another source.

Cannot connect to 
network server when 
attempting Remote 
System Installation.

The network controller is 
not configured properly.

Verify Network Connectivity, that a 
DHCP Server is present, and that 
the Remote System Installation 
Server contains the NIC drivers for 
your NIC.

System setup utility 
reports unprogrammed 
EEPROM.

Unprogrammed EEPROM. Flash the ROM.

Solving Network Problems (Continued)

Problem Cause Solution
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Solving Memory Problems

Ä
CAUTION: For those systems that support ECC memory, HP does not support mixing ECC and non-ECC 
memory. Otherwise, the system will not boot the operating system.

Solving Memory Problems 

Problem Cause Solution

System will not boot or 
does not function properly 
after installing additional 
memory modules.

Memory module is not 
the correct type or 
speed or the new 
memory module is not 
seated properly.

Replace module with the correct 
industry-standard device for the 
workstation.

On some models, ECC and non-ECC 
memory modules cannot be mixed.

Out of memory error. Memory configuration 
may not be set up 
correctly.

Use the Device Manager to check 
memory configuration.

You have run out of 
memory to run the 
application.

Check the application 
documentation to determine the 
memory requirements.

Memory count during POST 
is wrong.

The memory modules 
may not be installed 
correctly.

Check that the memory modules 
have been installed correctly and 
that proper modules are used.

Insufficient memory error 
during operation.

Too many Terminate 
and Stay Resident 
programs (TSRs) are 
installed.

Delete any TSRs that you do 
not need.

You have run out of 
memory for the 
application.

Check the memory requirements for 
the application or add more 
memory to the workstation.

Power LED flashes Red five 
times, once every second, 
followed by a two second 
pause, and the workstation 
beeps five times.

Memory is installed 
incorrectly or is bad.

1. Reseat DIMMs. 
2. Replace DIMMs one at a time to 

isolate the faulty module.
3. Replace third-party memory 

with HP memory.
4. Replace the system board.
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Solving Processor Problems
.

Solving Processor Problems

Problem Cause Solution

Poor performance is 
experienced.

Processor is hot. 1. Make sure the airflow to the 
workstation is not blocked.

2. Make sure the fans are 
connected and working 
properly (some fans only 
operate when needed).

3. Make sure the processor 
heatsink is installed properly.

Power LED is Red and  
stays on.

Processor is not seated 
properly or not 
installed.

1. Check to see that the processor 
is present.

2. Reseat the processor.
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Solving CD-ROM and DVD Problems

Solving CD-ROM and DVD Problems 

Problem Cause Solution

System will not boot from 
CD-ROM or DVD drive.

The CD-ROM or DVD 
boot is not enabled 
through the Computer 
Setup utility.

Run the Computer Setup utility and 
enable booting to removable media 
and verify boot order settings.

Non-bootable CD in 
drive.

Try a bootable CD in the drive.

CD-ROM or DVD devices 
are not detected or driver is 
not loaded.

Drive is not connected 
properly or not properly 
configured.

1. Reconnect power and data 
cables to the drive.

2. Install correct device driver.

Movie will not play in the 
DVD drive.

Movie may be 
regionalized for a 
different country.

See the documentation that came 
with the DVD drive.

Decoder software is not 
installed.

Install decoder software.

Cannot eject compact disc 
(tray-load unit).

Disc not properly seated 
in the drive.

1. Turn off the workstation and 
insert a thin metal rod into the 
emergency eject hole and push 
firmly. 

2. Slowly pull the tray out from the 
drive until the tray is fully 
extended, then remove the disc.

CD-ROM, CD-RW, 
DVD-ROM, or DVD-R/RW 
drive cannot read a disc or 
takes too long to start.

CD has been inserted 
upside down.

Re-insert the CD with the label 
facing up.

The DVD-ROM drive 
takes longer to start 
because it has to 
determine the type of 
media played, such as 
audio or video.

Wait at least 30 seconds to let the 
DVD-ROM drive determine the type 
of media being played. If the disc 
still does not start, read the other 
solutions listed for this topic.

CD or DVD disc is dirty. Clean CD or DVD with a CD 
cleaning kit.

Windows does not 
detect the CD-ROM or 
DVD-ROM drive.

1. Use Device Manager to remove 
or uninstall the device in 
question.

2. Restart the workstation and let 
Windows detect the device.
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Solving Drive Key Problems

Solving Internet Access Problems

Recording audio CDs is 
difficult or impossible.

Wrong or poor quality 
media type.

1. Try using a slower recording 
speed.

2. Verify that you are using the 
correct media for the drive.

3. Try a different brand of media. 
Quality varies widely between 
manufacturers.

Solving CD-ROM and DVD Problems (Continued)

Problem Cause Solution

Solving Drive Key Problems

Problem Cause Solution

Drive key is not seen as a 
drive letter in Windows XP.

The drive letter after the 
last physical drive is not 
available.

Change the default drive letter for 
the Drive key in Windows XP.

The workstation boots to 
DOS after making a 
bootable Drive key.

Drive key is bootable. Install the Drive key after the 
operating system boots.

Solving Internet Access Problems 

Problem Cause Solution

Unable to connect to the 
Internet.

Internet Service Provider 
(ISP) account is not set 
up properly.

Verify Internet settings or contact the 
ISP for assistance.

Modem is not set up 
properly.

Reconnect the modem. Verify the 
connections are correct using the 
quick setup documentation.

Web browser is not set 
up properly.

Verify that the Web browser is 
installed and set up to work with 
your ISP.

Cable/ DSL modem is 
not plugged in.

Plug in cable/DSL modem. You 
should see a “power” LED light on 
the front of the cable/DSL modem.
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Unable to connect to the 
Internet. (continued)

Cable/DSL service is 
not available or has 
been interrupted due to 
bad weather.

Try connecting to the Internet at a 
later time or contact your ISP. (If the 
cable/DSL service is connected, the 
“cable” LED light on the front of the 
cable/DSL modem will be on.)

The CAT5 10/100 
cable is disconnected.

Connect the CAT5 10/100 cable 
between the cable modem and the 
workstation’s RJ-45 connector. (If the 
connection is good, the “PC” LED 
light on the front of the cable/DSL 
modem will be on.)

IP address is not 
configured properly.

Contact the ISP for the correct IP 
address.

Cookies are corrupted. Windows 2000
1. Select Start > Settings > 

Control Panel.
2. Double-click Internet 

Options.
3. On the General tab, click the 

Delete Cookies button.
Windows XP
1. Select Start > Control 

Panel.
2. Double-click Internet 

Options.
3. On the General tab, click the 

Delete Cookies button.

Cannot automatically 
launch Internet programs.

You must log on to the 
ISP before some 
programs will start.

Log on to the ISP and launch the 
desired program.

Solving Internet Access Problems (Continued)

Problem Cause Solution
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Internet takes too long to 
download Web sites.

Modem is not set up 
properly.

Verify that the correct modem speed 
and COM port are selected.
For Windows 2000
1. Select Start > Settings > 

Control Panel.
Continue with step #2
For Windows XP
1. Select Start > Control 

Panel.
Continue with step #2
2. Double-click System.
3. Click the Hardware tab.
4. In the Device Manager area, 

click the Device Manager 
button.

5. Double-click Ports (COM & 
LPT).

6. Right-click the COM port your 
modem uses, then click 
Properties.

7. Under Device status, verify 
that the modem is working 
properly.

8. Under Device usage, verify 
the modem is enabled.

9. If there are further problems, 
click the Troubleshoot button 
and follow the on-screen 
instructions.

Solving Internet Access Problems (Continued)

Problem Cause Solution
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System Board and Riser Board Reference 

Designators

These reference designators are used on most but not all hp system and riser boards.

Designator Component 

BT1 
CR1 
CR2 
CR3 
CR11

Battery socket/Battery 
LED - 3.3V Aux 
LED - Power button press 
LED - PS_ON (off), 5.5V Aux (on) 
CPU reset LED

CR34 
CR35 
E14 
E49 
E50

Power ON LED 
Hard drive activity LED 
Boot block header/jumper 
Clear Password header/jumper 
Clear CMOS header

H5 
J6 
J7

RTC clock crystal/Tie-down 
BNC 
RJ-45 Jack

J9 
J10 
J11 
J12  
J13 - 19 
J20 - 29 
J30 
J31 - J35

Stacked RJ45/Dual USB connector 
ISA slot 
IEEE 1394 
IEEE 1394 
ISA slots 
PCI slots 
Riser board socket 
Device Bay connectors

J36 
J37 
J38 
J39 
J40

AC97 connector 
Primary SCSI connector 
Secondary SCSI connector 
Stacked parallel/SCSI connector 
AGP slot

J50 
J51 
J52 
 

First parallel port 
Second parallel port 
Double-stacked parallel port 
Top Port B 
Bottom Port A
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J53 
J54 
J55 
J65 
J66 
J67

Parallel port over single Serial Port 
Parallel port over Serial Port and Video Port 
Parallel port over dual VGA ports 
DVI connector 
Keyboard connector (Closest to power supply) 
Mouse connector

J68 
 
 
J69 
J70

Double-stacked mouse/keyboard connector 
Top      Mouse 
Bottom  Keyboard 
Video connector 
Primary single USB connector

J71 
J72 
J73 
J74 
J75

Secondary single USB jack 
Microphone jack 
Line-in jack 
Line-out jack 
Headphone jack

J76 
J77 
 

Volume control 
Double-stacked headphone/microphone connector 
Top Microphone 
Bottom Headphone

J78 
 
 
J80

Double-stacked line-in/line-out connector 
Top Line in 
Bottom Line out 
Stacked serial/audio connector

J81 
 
 
J82 
 

Primary double-stack USB 
Top Port 2 
Bottom Port 1 
Secondary double-stack USB 
Top Port 4 
Bottom Port 3

J83 
J101 
J113 
JP49 
L1

Triple-stacked audio jack (line in, line out/headphone, microphone) 
Security board connector for security card 
Video cache connector 
Clear password header/jumper 
USB front port choke

L2 
L3 
L4 
P1

USB rear port choke (1st) 
USB rear port choke (2nd) 
USB rear port choke (3rd) 
P/S connector

P3 
P4 
P5 
P6

VCCP 12V header  
Secondary processor 12V header 
Main Power/HDD LED connector  
Speaker connector

Designator Component (Continued)
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P7 
P8 
P9 
P10 
P11

Audio connector (from CD-ROM) 
Primary chassis fan connector 
Secondary chassis fan header 
Diskette drive connector 
Second Audio connector

P12 
P13 
P15 
P16 
P20 
P21

Alert on LAN NIC connector 
VRM module connector 
AUI connector 
Fan command/fan sink header 
Primary IDE connector 
Secondary IDE connector

P22 
P23 
P24 
P25 - P26 
P27

Slimline CD-ROM connector 
Header for front audio panel 
Header for front panel USB 
Video memory upgrade connector 
MultiBay header (available on select HP systems only)

P29 
P30 
P31 
P50 
P52

SCSI LED connector 
Primary serial ATA (SATA) port 
Secondary serial ATA (SATA) port 
Serial debug header 
Serial port header

P53 
P54 
P55 
 

First serial port 
Second serial port 
Double stack serial port 
Top            Serial B 
Bottom        Serial A

P58 
P64 
P65 
P70 
P71

Riser edge connector (male-mates with J30) 
VSFF expansion connector 
Graphics option connector 
Primary (CPU) fan header for fansink 
Secondary CPU fan header for fansink

P89 
P100 
P101 
P120 
P124

Floating serial port /COM port header 
ITP connector 
Security card connector, system board 
Secondary chassis fan header 
Hood lock header

P125 
P216 
SW1 
SW2 
SW50

Hood sensor header 
White box chassis fan 
Processor speed switch 
Security hood switch 
Clear CMOS switch/push button

Designator Component (Continued)
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SW51 
SW52 
U7 
U15 
U100
XBT1

Power button switch 
System reset switch 
64-bit bridge chip for Workstation group 
ROM chip 
Security chip 
Battery socket

XMM1 
XMM2 - XMM5 
XU1 
XU2 
XU15

Memory slot. DIMM1 or RIMM1 populated and tested 
Following memory slots 
Primary processor socket Secondary processor socket 
ROM socket 
ROM socket

XU100 
Y1 
Y2 
Y3 
Y4 
Y5

Security chip socket 
Primary (TH) system clock crystal 
Secondary (SMT) system clock crystal 
Primary (YTH) NIC clock crystal 
Secondary (SMT) NIC clock crystal 
RTC clock crystal/tie-down

Designator Component (Continued)
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Memory

Your workstation has double data rate synchronous dynamic random access memory 
(DDR-SDRAM) dual inline memory modules (DIMMs).

The memory sockets on the system board can be populated with up to four industry-standard 
DIMMs. These memory module slots are populated with at least one preinstalled memory 
module. To achieve the maximum memory support, you can populate the system board with up 
to 4GB of memory configured in a high-performing dual channel mode.

For proper system operation, if the workstation supports DDR-SDRAM DIMMs, the DIMMs 
must be industry-standard 184-pin, PC2700 333 MHz-, or PC3200 400 MHz-compliant, 2.5 volt 
DDR-SDRAM DIMMs. The DDR-SDRAM DIMMs must also:

■ support CAS latency 2, 2.5, or 3 (CL = 2, CL = 2.5, CL=3)

■ contain the mandatory JEDEC SPD information

In addition, the workstation supports:

■ 128Mbit, 256Mbit, and 512Mbit non-ECC memory technologies

■ single-sided and double-sided DIMMS 

■ DIMMs constructed with x8 and x16 DDR devices; DIMMs constructed with x4 SDRAM 
are not supported 

The following processor bus frequencies are required for the system to run at the supported 
memory frequencies.

If a memory frequency is paired with an unsupported processor bus frequency, the system will 
run at the highest supported memory speed. For example, if a 333 MHz DIMM is paired with a 
400 MHz processor bus, the system will run at the lower supported memory speed.

✎ The system will not start if you install unsupported DIMMs.

Memory Frequency Required Processor Bus Frequency

333 MHz 533 MHz or 800 MHz

400 MHz 800 MHz
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Memory
DIMM Sockets
There are four DIMM sockets on the system board, with two sockets per channel. The sockets are 
labeled XMM1, XMM2, XMM3, and XMM4. Sockets XMM1 and XMM2 operate in memory 
channel A. Sockets XMM3 and XMM4 operate in memory channel B.

 

The system will automatically operate in single channel mode or a higher-performing dual 
channel mode, depending on how the DIMMs are installed. 

■ In single channel mode, the maximum operational speed is determined by the slowest DIMM 
in the system. For example, if the system is populated with a DIMM that is 333 MHz and a 
second DIMM that is 400 MHz, the system will run at the slower of the two speeds.

■ In dual channel mode, the DIMM pairs must be identically matched. DIMMs in the XMM1 
and XMM3 black sockets must be identical; DIMMs in the XMM2 and XMM4 blue sockets 
must also be identical. Therefore, if you have one preinstalled DIMM in socket XMM1 and 
are adding a second DIMM, it is recommended that you install an identical DIMM into the 
XMM3 socket. 

■ In dual channel mode, the DIMM pairs must be identically matched. DIMMs in the XMM1 
and XMM3 black sockets must be identical; DIMMs in the XMM2 and XMM4 blue sockets 
must also be identical. Therefore, if you have one preinstalled DIMM in socket XMM1 and 
are adding a second DIMM, it is recommended that you install an identical DIMM into the 
XMM3 socket. If you are populating all four DIMM sockets, use identical DIMMS in each 
socket. Otherwise, the system will not operate in dual channel mode.

Item Description Socket Color

1 DIMM socket XMM1, Channel A Black

2 DIMM socket XMM2, Channel A Blue

3 DIMM socket XMM3, Channel B Black

4 DIMM socket XMM4, Channel B Blue
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Ultra ATA Drive Guidelines and Features

Ultra ATA Jumpers
Ultra ATA drives are configured by means of jumper settings. Factory-installed drives ship with 
the jumpers preset to the cable-select mode; therefore, no jumper setting changes are required on 
factory pre installed, replacement, or option drives. With cable-select, the drive is configured as 
either Master (Drive/Device 0) or Slave (Drive/Device 1) by its physical attachment to the cable. 

If you purchase a third-party hard drive, refer to the documentation included with the drive kit to 
ensure proper cable installation and configuration.

✎ All drives on a controller channel need to have their jumpers either in the cable-select mode or 
have the individual drive jumper installed on the appropriate Master (Drive/Device 0) or Slave 
(Drive/Device 1) position.

Ultra ATA Cables
When installing a second device on either the primary or secondary controller, you must use an 
industry standard 80-conductor Ultra ATA cable for optimal performance. These cables have a 
maximum length of 18 inches and a maximum distance of 6 inches between the two devices for a 
two-drive cable.

Drives operating at speeds faster than those of the Ultra ATA-33 devices require 
industry-standard 40-pin, 80-conductor cables to maintain the higher data transfer rates possible 
with the improved technology. 

When using Ultra ATA-133, -100, -66, and slower -33 drives in the same system, each drive will 
operate at its appropriate data transfer rate.

Cable Layout
The faces of industry-standard cable connectors are color coded for easy recognition:

■ System board connector = blue face

■ Device 0 connector = black face

■ Device 1 connector = gray face

✎ The color code of an industry-standard cable is valid only if the drive’s jumper is in the 
cable-select position.
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Single-Drive Cable

Two-Drive Cable

On a two-drive cable, the Drive/Device 0 connector is always the farthest one from the system 
board connector and the Drive/Device 1 connector is always the closest to the system board 
connector. 

✎ Some cables may be labeled “Drive 0” instead of “Device 0” and “Drive 1” instead of 
“Device 1”. 

Drive Installation Guidelines
Your workstation supports three drive bays and contains two ATA (IDE) controller channels with 
a dedicated connector on the system board for each controller. One controller is designated as the 
primary and the other as the secondary. Each controller can have up to two devices attached to it 
via an industry-standard 80-conductor cable.

✎ To install a secondary hard drive, you must use a dual-headed cable (PN 108950-051).

Any drive attached to a ATA controller must have a drive designation, such as Device O (Master 
Drive) or Device 1 (Slave Drive). Drives set to the cable select mode will automatically be 
designated as Device 0 or Device 1 depending on where they are connected on the device cable 
and whether or not they are the only drive connected to the cable. For optimal performance of 
your system, all drives need to be attached to the primary and secondary ATA controllers in a 
specified sequence. This sequence is determined by the device class and by specific attach 
sequence rules.

Device Classes
In order to determine the best drive attach sequence, ATA/ATAPI drives are segregated into four 
different classes based upon the bandwidth demands they place on an ATA controller. The most 
demanding devices are in Class 1 and the least demanding are in Class 4.

System 
Board

Device 0
(master)

Black 
Face

Blue 
Face

System 
Board

Device 1
(slave)

Device 0
(master)

Black 
Face

Blue 
Face

Gray 
Face
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✎ The above classifications are used as examples only. Your system may or may not support some 
Class 4 drives. A diskette drive is Class 4, however, this drive has an exclusive connector on the 
system board and is not considered when “counting” the number of devices allowed on a given 
ATA controller. For a hardware compatibility list for your specific system, please refer to 
www.hp.com/support.

General Attach Guidelines
■ The lower the device class number, the faster the device and the more bandwidth required. 

■ Drives installed in the Device 0 positions on both the primary and secondary controllers 
receive the greatest possible bandwidth.

■ The bootable ATA hard drive should always be installed on the primary controller in the 
Device 0 position.

Device Attach Sequences

Scenario One: a system has two devices. Using the Device Class Table above, the device class 
for each is identified as:

■ Ultra ATA-100 hard drive = Class 1

■ DVD-ROM drive = Class 2

Class 1 
Hard 
Drives

Class 2 
High Speed 

Optical Drives

Class 3
Optical Storage 

Drives

Class 4
Magnetic 

Storage Drives

ATA-100 
ATA-66 
ATA-33

DVD 
DVD-CD R/W

R/W CD-ROM  
CD-ROM 

LS-120
Tape
Zip 
Diskette

Attach Sequence - Two Device

Device Name Device Class
Position 
Number ATA Controller

Device 
Number

Ultra ATA-100 hard drive 1 1 Primary 0

DVD-ROM drive 2 2 Secondary 0
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Scenario Two: a system has three devices. Using the Device Class Table in Section 4.3.1, the 
device class for each is identified as:

■ Ultra ATA-100 hard drive = Class 1

■ Ultra ATA-100 hard drive = Class 1

■ CD-ROM drive = Class 3

Attach Sequence - Three Device

Device Name
Device 
Class

Position 
Number

Controller 
Name

Device 
Number

Ultra ATA-100 hard drive 1 1 Primary 0

Ultra ATA-100 hard drive 1 4 Primary 1

CD-ROM drive 3 2 Secondary 0

Primary 
Controller

Empty
4

HDD
1

Secondary 
Controller

Empty
3

DVD-ROM
2

Device 1 Device 0

Device 1 Device 0

Primary 
Controller

HDD
4

PrimaryHDD
1

Secondary 
Controller

Empty
3

CD-ROM
2

Device 1 Device 0

Device 1 Device 0
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Ultra ATA Drive Guidelines and Features
Additional Drive Application Notes
■ When replacing a hard drive, the replacement should be of the same type (Ultra ATA -33, 

-66, or -100) as that being removed to retain the same level of performance.

■ Your system supports a maximum of three drives. A second hard drive can be install in your 
system; however, you MUST remove the diskette drive to create an available drive bay.

■ Some graphics cards (such as the nVIDIA Quadro4 400 NVS) will require the removal of the 
diskette drive (or hard drive, if installed) in bay 1. See Chapter 5 for Drive Positions.

SMART Drives
The Self Monitoring Analysis and Recording Technology (SMART) ATA drives for HP 
workstations have built-in drive failure prediction that warns the user or network administrator of 
an impending failure or crash of the hard drive. The SMART drive tracks fault prediction and 
failure indication parameters such as reallocated sector count, spin retry count, and calibration 
retry count. If the drive determines that a failure is imminent, it generates a fault alert.

Drive Capacities
The combination of the file system and the operating system used in the workstation determines 
the maximum usable size of a drive partition. A drive partition is the largest segment of a drive 
that may be properly accessed by the operating system. A single hard drive may therefore be 
subdivided into a number of unique drive partitions in order to make use of all of its space. 

The table that follows identifies the capabilities and restrictions imposed on the workstation by 
the combinations of BIOS, file and operating systems.

Microsoft to Drive Manufacturer Size Conversion Table*

Drive Size as Identified by Microsoft 
Operating System

Drive Size as Identified by 
Drive Manufacturers

40 GB 42.9 GB

80 GB 85.9 GB

160 GB 171.7 GB

*Drive size calculations by drive manufacturers are bytes to the base 10 while calculations by 
Microsoft are bytes to the base 2.

Drive/Partition Capacity Limits

File 
System

Controller 
Type Operating System

Drive 
Size

Max 
Partition 

Size
Max # of 
Partitions

FAT 32 ATA Windows 2000/ XP 128 GB 32 GB 4

NTFS ATA Windows 2000/XP 128 GB 128 GB 1
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Index

4-pin power pin assignments A–6
24-pin power pin assignments A–6

A
advanced, Computer Setup heading 2–10
AGP card

pin assignments A–5
ATA/ATAPI (IDE) drive cable pin assignments 

A–4

B
battery

disposal 4–7
real-time clock D–2
SFF removal and replacement 5–26

blank screen D–9

C
cable

hard drive 5–21
proper handling 4–7
SFF optical drive 5–18

cable lock
SFF 5–4

cable select drive G–1
categories, Diagnostics for Windows 2–14
cautions

AC power 4–1
adding devices 1–1
batteries 4–7
cables 4–7
cooling fan 4–6
installation 1–1
keyboard cleaning 4–5
keyboard keys 4–5

chassis
SFF illustrated 4–1

chassis types, illustrated 4–1
cleaning

computer 4–4
keyboard 4–5
monitor 4–5
mouse 4–5

computer
cleaning 4–4

computer pauses D–2
Computer Setup

heading
advanced 2–10
file 2–4
security 2–7
storage 2–4

utilities 2–3
Configuration Record Utility 2–17
connector pin assignments ?? to A–6
country-specific power cord set requirements B–2

D
date and time display D–2
device drivers

installing/upgrading 1–1
Diagnostics for Windows

categories 2–14
detecting 2–13
installing 2–13
Menu Bar 2–15
overview 2–13
running tests 2–16

disassembly preparation
SFF 5–1

diskette drive bezel
SFF removal and replacement 5–8

drive
cable select G–1
capacities G–5
device designation G–1
partition size G–5
replacement type G–5

drive positions
SFF 5–15

E
electrostatic discharge. See ESD
error messages, POST C–1 to ??
ESD (electrostatic discharge)

information 4–2
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Index
materials and equipment 4–3
preventing damage 4–2

Ethernet
AUI pin assignments A–2
BNC pin assignments A–1
RJ-45 pin assignments A–1

expansion card
SFF AGP socket 5–13
SFF removal and replacement 5–12
SFF standard socket 5–13

expansion card cage
SFF removal and replacement 5–10, 5–11

expansion slot cover
SFF, removal and replacement 5–12

external 3.5-inch drive
SFF removal and replacement 5–19

F
FailSafe key

SFF 5–2
fan

power supply 4–6
FAT 32 to NTFS conversion 1–2
file, Computer Setup heading 2–4
front bezel

SFF removal and replacement 5–7
front I/O devices

SFF removal and replacement 5–23

G
grounding methods 4–3

H
hard drive

disconnecting cables 5–21
proper handling 4–7

headphone pin assignments A–3
heatsink

SFF removal and replacement 5–29
hood sensor, SFF 5–3
HP software. See software

I
infrared (IR) transceiver, external, pin assignments 

A–3
installing Diagnostics for Windows 2–13
IR transceiver. See infrared (IR) transceiver

J
jumper settings D–7

K
keyboard

cleaning 4–5
pin assignments A–1

L
line-in audio pin assignments A–3
line-out audio pin assignments A–3

M
memory

dual channel mode F–2
SFF removal and replacement 5–9

menu bar, Diagnostics for Windows 2–15
microphone pin assignments A–3
microtower

front drive bezel removal and replacement 5–8
monitor

blank screen D–9
blurry video D–10
checking connections D–1
cleaning 4–5
dim characters D–10
pin assignments A–4

mouse
cleaning 4–5
pin assignments A–1

O
optical drive

connecting SFF cables 5–18
SFF removal and replacement 5–16

P
padlock

SFF 5–5
parallel interface pin assignments A–2
password

power-on 2–1
POST (Power-On Self-Test) 2–1
POST error messages C–1 to C–7
power cord set requirements

country specific B–2
general B–1

power supply
fan 4–6
SFF removal and replacement 5–31

power switch assembly
SFF removal and replacement 5–24

power-on password 2–1
Power-On Self-Test (POST) 2–1
primary hard drive

SFF removal and relacement 5–21
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Index
problems
audio D–12
CD-ROM and DVD D–22
diskette D–5
display D–9
drive key D–23
hard drive D–6
installing hardware D–16
Internet access D–23
keyboard D–15
memory D–20
network D–18
optical drives D–22
power supply D–4
printer D–14

processor
SFF removal and replacement 5–29

protecting software 2–19

R
Remote Diagnostics Enabling Agent 2–18
removal and replacement

microtower front drive bezel 5–8
SFF AGP card 5–13
SFF battery 5–26
SFF cable lock 5–4
SFF diskette drive bezel 5–8
SFF expansion card 5–12
SFF expansion card cage 5–10, 5–11
SFF expansion slot cover 5–12
SFF external 3.5-inch drive 5–19
SFF front bezel 5–7
SFF front I/O devices 5–23
SFF heatsink 5–29
SFF memory 5–9
SFF optical drive 5–16
SFF padlock 5–5
SFF power supply 5–31
SFF power switch assembly 5–24
SFF primary hard drive 5–21
SFF riser card 5–11
SFF Smart Cover Lock 5–2
SFF speaker 5–29, 5–30
SFF system board 5–25

required tools and software 4–6
restoring software 2–19
riser board

designators E–1

riser card
SFF removal and replacement 5–11

running tests,Diagnostics for Windows 2–16

S
safety precautions 4–4
safety precautions, cleaning 4–4
screws, correct size 4–6
SDRAM (synchronous dynamic random access 

memory) F–1
security

Computer Setup heading 2–7
SFF 5–4

serial interface pin assignments A–2
service considerations 4–6
setup

software 1–2
windows 1–1

SFF
battery removal and replacement 5–26
cable lock 5–4
chassis, illustrated 4–1
disassembly preparation 5–1
diskette drive bezel removal and replacement 

5–8
drive positions 5–15
expansion card cage removal and replacement 

5–10, 5–11
external 3.5-inch drive removal and replacement 

5–19
external security 5–4
FailSafe key 5–2
front bezel removal and replacement 5–7
front I/O devices removal and replacement 5–23
hood sensor 5–3
memory removal and replacement 5–9
optical drive removal and replacement 5–16
padlock 5–5
power supply removal and replacement 5–31
power switch assembly removal and 

replacement 5–24
preparation for disassembly 5–1
riser card

removal and replacement 5–11
Smart Cover Lock 5–2
speaker removal and replacement 5–30
system board removal and replacement 5–25
tamper-proof screws 5–2

Small Form Factor. See SFF
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Smart Cover Lock
SFF 5–2

software
Computer Setup Utilities 2–1
protecting 2–19
required 4–6
restoring 2–19
setup 1–2

spare part number
wrench, tamper resistant 4–6

speaker
SFFremoval and replacement 5–30

static electricity 4–2
storage, Computer Setup heading 2–4

system board
designators E–1
SFF removal and replacement 5–25

T
tamper-proof screws

SFF 5–2
tools, required 4–6

U
USB pin assignments A–3

W
Wake-on-LAN feature D–18
warnings

battery 4–7
wrench, tamper-resistant 4–6
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